RangeRovers.net Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
665 Posts
Discussion Starter #1
a buddy of mine was selling his 92 classic, was white but is now green (even better) with tan leather. needs assembly but seems alright, especially for $600!
 

·
Registered
Joined
·
665 Posts
Discussion Starter #3
I have a 95 disco and a 2001 Hse... it's like hotel California, i checked out but never left... I need a series I and a defender to get the whole set

is the blower motor known to go bad on these? I dont remember hearing about it, and they half disassembled the dash to get to it
 

·
Registered
Joined
·
1,395 Posts
I think it may have come up before.

Didn't they start with the heater and then build the rest of the car around it...?
 

·
Registered
Joined
·
269 Posts
If your blower is not working I would start with the resistor. Looks like a good buy, my rangie is currently going from green to white, lol.
 

·
Registered
Joined
·
23 Posts
I have a similar problem with my heater in my '90 Classic. The 2 slower speeds are not working. Full power is. There are 3 resistors, 0.5 ohm, 1.5 ohm and 2.0 ohm to control the speeds.

I will have to take most of the dash apart to get to the resistors. What I have found, this is a 2 day job. Worse is to find new resistors. There is a solution where the resistors are not put in the motor housing, but where you can get at them easily. You will anyway have to take everything apart to install it.
 

·
Registered
Joined
·
665 Posts
Discussion Starter #7
ad a chance to look at her today, the 2 fans in the right footwell spin, only at low speed. I can't see the 3rdf fan but i dont hear ir coming on. the 2nd relay from the front is missing, i tink that was the heater/ vent relay, tried jumping it out but to no avail. I have a missing switch, looked to be the 4 position switch on the left, to energise ac, cant find it. the vent duct is seized open.

Where are the resistors located? I dont think the 3rd fan is bad yet, just cant find a relay 5 that switches between the 2 fans and the third ones, non have the same colors.
 

·
Registered
Joined
·
665 Posts
Discussion Starter #9
where is the edit button?


also, is there only one blower resistor for all the fans or is the single fan constant speed?
 

·
Registered
Joined
·
269 Posts
Its under the decker/cowl, pass side. Its prone to failure. Take your plastic grills out and have a look at it you should be able to see if it looks good. If you have to replace it hopefully you can get it out through the grill holes. If not you have to remove the hood in order to get the decker panel off.
 

·
Registered
Joined
·
665 Posts
Discussion Starter #12
while under there,I checked the fan, seized. got it freed up a bit, with generous appllication of oil with my telescopic oiler, even had the motor run, but then I'm guessing i must have hit the brushes as it stopped altogether. looks like i'll be in there to pull the motor out after all. Somebody did some work, found some duct tape in the dash. I'm seeing 16 Mohms, sounds like a layer of film on the brushes.
A nice big picture of what the motor looks like would be nice, searched the net for an hour.
 
1 - 13 of 13 Posts
Top