RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
have a strange issue on a 13 RRS where the wipers will intermittently not work, everything will work fine and then they just stop working. Sometimes everything will work shut the car off go into store and come out to no wipers and then a day later the wipers are back to life. Just putting this out there to see if anyone has had similar issues while i begin the real dive into the diag to see what i can find.
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
517 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #3
do they stop working altogether or just stop working in auto mode? If it is auto mode make sure the windshield is clean in front of the rain sensor. Also check out this post to see if any of this is your issue.
https://www.rangerovers.net/forum/6-range-rover-mark-iii-l322/40281-blocking-protection-problem-front-wipers.html
they stop working all together at any speed, i have had the car off overnight and they still do not come back to life. I saw that thread and changed the relays already and it still has the issue, I really need to get a wiring diagram so i can see if here is more relays for the wipers than the one in the fuse box.
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
101 Posts
I found a wiring diagram online not sure if it is allowed to be posted, anyone know? It's over 1100 pages. If so I can make a new thread for it with the link.
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
101 Posts
Posted on a new thread, as well as repair guide
 
1 - 7 of 7 Posts
Top