RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi folks, first time posting, so hi, problem is welll, took the 1998 range with the 2.5 bmw Diesel engine for an mot, passed but coming out I had no dash lights/ windows/mirror adjust or stereo, got home, looked at the problem, found out a cable got trapped in the hand brake mech( not one that goes into the window center console, there is another cable in there that’s not connected to anything) did have a little electric burn smell when I replaced the fuse( did go through a few on fault finding) can I have your thoughts weather it going to be centre consol still or burnt something out in BECM fuse box that causing it, any help would be appreciated, that in advance. Adey
 

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Sorry forgot to add, got dash working, stereo on same fuse works too, just windows/ mirrors/sunroof don’t work now, would be interested in finding out what that other unconnected cable is for( 2 cables in one socket) oh and it’s an Autos forgot that too sorry
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
4,198 Posts
All windows/sunroof/etc not working can be a sign of a bad window switchpack - they can and do just randomly fail at times - I repair them, and see various faults. (sadly I'm not home until April or I'd offer to sell you a serviced one on exchange if that's the problem!)

But since you have mentioned trapped wires, I would be inspecting to make sure that there is good power/ground connections (in case there is internal damage in one of the wires to the switchpack connector.
The black wire to the connector is the connection to ground, and the Purple/Blue wire should have permanent 12V on it. So something (easy and free!) to check to start with.

The other connector... that's for vehicles with the rear footwell light under the back of the center console unit. When installed, it's wiring runs back up under the center console and plugs into that other connector.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for the reply, the cable that got caught and caused the short was the one that you say runs to supply light to rear footwell, the centre consol still lights up when lights are turned on, I’ll start checking the cables that you mentioned(supply/ground)
Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
All windows/sunroof/etc not working can be a sign of a bad window switchpack - they can and do just randomly fail at times - I repair them, and see various faults. (sadly I'm not home until April or I'd offer to sell you a serviced one on exchange if that's the problem!)

But since you have mentioned trapped wires, I would be inspecting to make sure that there is good power/ground connections (in case there is internal damage in one of the wires to the switchpack connector.
The black wire to the connector is the connection to ground, and the Purple/Blue wire should have permanent 12V on it. So something (easy and free!) to check to start with.

The other connector... that's for vehicles with the rear footwell light under the back of the center console unit. When installed, it's wiring runs back up under the center console and plugs into that other connector.


Thanks again for that info, got round to looking into it eventually, no power to pack, temporary fix have installed a jump cable from cigarette lighter socket, every thing now works as it should,
Thanks again
Adey
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
31 Posts
I ran the line from the battery to the starter under the tranny and it shorted out and manifested in the e brake. Smoke would come out of center console when i cranked up. Check that.
 
1 - 7 of 7 Posts
Top