RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter #1
After a battery swap i went to set all my windows. The drivers side will not set !Ive tried over and over. The others set totally fine. Its weird. Also, it started making this noise when rolling it up. Once its reached the highest point, it makes a sound like an impact wrench as the motor keeps going up and up, with no where to go. Is it trying to keep going because its not set, or is the regulator busted and thats why it WONT set. ? chicken or the egg....

- g
 

·
Registered
Joined
·
151 Posts
Hi mate it sounds like a couple of teeth have stripped on the window regulator.
My window made exactly the noise you described and on investigation two teeth had broken off the regulator so a new unit was fitted.
Just take the door trim off you should be able to see if the regulator is missing any teeth.
 

·
Registered
Joined
·
640 Posts
Sounds like Teeth Stripped on Either Drive Motor Gear or Regulator you will need to Remove Door Panel of to Investigate.

Cheers
 

·
Registered
Joined
·
61 Posts
i have exactly the same problem. i have been meaning to take the panel off to have a look.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
669 Posts
Will definitely be the 'cog/ratchet' - you'll find teeth missing and probably some tearing of the metal frame the motor is attached to (top right usually near to a fixing bolt frame to door). Some repair the teeth with weld then grinding back to shape but if you've got the tears the cost is not bad to replace the whole mech (reusing the motor of course)

Hardest bit is keeping the glass out of the way - I used baling string as I had no 'little helpers'

All told took 2 hours start to finish and I'd never done it before

Window SETS, 1 touch now works, alarm now works (someone had unplugged the connector in the engine bay - when I reconnected it it chirped everytime I set it) so win win and win again!
 

·
Registered
Joined
·
129 Posts
Discussion Starter #6
Good to know guys! thanks!

-grae
 

·
Registered
Joined
·
129 Posts
Discussion Starter #7
Installed a new regulator, solve all issues...

Now someone please answer.... what was the logic of pop riveting the factory unit into place? This just seems likes a cut corner to save some production costs. The rivets obviously come loose over time.... leading to these issues. The old unit i pulled out was actually repaired as some point with some weld where the regulator frame had ripped apart. :thumb:
 
1 - 7 of 7 Posts
Top