RangeRovers.net Forum banner

21 - 31 of 31 Posts

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
327 Posts
Just came back from a 200 mile drive at freeways speeds (72 mph) - no sound at all. This is a drive a do regularly and always get the hooting sound - so I'm cautiously optimistic.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
79 Posts
Discussion Starter #22
I have the kit, I'll install this weekend. Thanks again sowr.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
327 Posts
Hope it works out for you!
 

·
Registered
2016 Range Rover Sport HSE
Joined
·
67 Posts
I need to do this desperately and have a road trip to Park City tomorrow. Can't wait to listen to the hmmming for 6.5 hours... Should probably take the girlfriends ML350 but we took it a few weeks ago and although its very nice the Rovers SC engine just is so much better. Thanks for posting the instructions as someone who is not very handy it really is a huge help!
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
7 Posts
My 2012 Supercharged just started doing this same thing. Mine only does it with the recirc off. Hopefully the same fix. I'll try soon. Thanks for the info!
 

·
Registered
2013-2015 Range Rover MkIII / L322
Joined
·
40 Posts
I just bought this seal kit from my local Land Rover dealer. They had to bring it in from the Toronto warehouse but had it within a week. I’m going to install the new seal soon as I’ve had the annoying noise for the last 4 years whenever the wind is right (normally a bad cross wind) and with the Recirculation turned on or on the Auto setting. If I would take the Recirc off of Auto to shut it off and just pull fresh air the noise would quit immediately. Hopefully the new seal kit fixes this issue.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
327 Posts
I posted some instructions for adding the kit. It worked for a while but now the noise it back. Fortunately, I have found an easy fix; as soon as the noise starts I turn the heat controls from 72 to MAX and the noise goes away. The kit's instructions have the fix applied to one flap only - maybe doing both flaps will work. Or maybe some felt on the seal would work.
 

·
Registered
Joined
·
595 Posts
I about died laughing when I saw "hoot/zoot" ... this is so accurate. I am experiencing the same phenomenon and will be purchasing a kit. Thanks for addressing this!
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
79 Posts
Discussion Starter #30
I posted some instructions for adding the kit. It worked for a while but now the noise it back. Fortunately, I have found an easy fix; as soon as the noise starts I turn the heat controls from 72 to MAX and the noise goes away. The kit's instructions have the fix applied to one flap only - maybe doing both flaps will work. Or maybe some felt on the seal would work.
Yes,my kit worked for a while then the noise came back.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
69 Posts
I seem to have the same problem. Has anyone found a definitive solution?
 
21 - 31 of 31 Posts
Top