RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
2008 Range Rover L322 HSE
Joined
·
204 Posts
Discussion Starter #1
Well now that my youngest Daughter has started driving, I pulled lucky out of the shop (our Barn/shop) and got the tags renewed as its been sitting mostly for the last year and started her driving it.
All has been well last few weeks and the other day, it went into EAS Fault. I did a reset and it pumped right up and all was well. I did replace the front air bags about 3 years ago with Gen2 and when I got it out of the shop replaced the rears with Gen2's as well.

This morning I tore into it and found the Valve block has a leak or two and found the Blue hose from pump to valve block ha a pinhole.
Where would one find a replacement blue hose? I found one on ebay for 74.00..seems a bit high for a 10" piece of hose.

Ordering a valve block oring kit today as well...Last rebuilt the valve block about 6-7 years ago.

Thanks!!
Bruce
 

·
SUPER MODERATOR
Joined
·
27,755 Posts
Whoever you order your rebuild kit should have it. Email Scotty and see if he has a roll in stock to lop you off a length. He will also have your rebuild kit.
 

·
Registered
2008 Range Rover L322 HSE
Joined
·
204 Posts
Discussion Starter #3
Parts ordered, Scotty had it all. New oring kits and some tubing.

Thanks!!
 

·
Registered
2008 Range Rover L322 HSE
Joined
·
204 Posts
Discussion Starter #4
I have concluded I Hate Range Rovers Now.

On The 96 I Rebuilt EAS Pump and Valve Block, New Rear air Bags and fairly new Fronts.

Front drops to bump stops every other night, pumps right up when started. Now EAS Fault.

On 2000, New airbags all the way around, Rebuilt Valve block and Front right inflates to max height and rear left deflates to bump stops in a few hours.

I still need to look for leaks but 2000 is worse than before rebuild. 96 is better but still has issues.

Seems when you fix one thing, 3 more things break.
 
1 - 4 of 4 Posts
Top