RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
2003 Range Rover HSE l322 with 100k miles. The HDC inactive / air suspension inactive message has been intermittent but finally decided to stay on. I used the RSW solution allcoms and in said open circuit right front wheel speed sensor. Thinking it was a sensor, I swapped the left and right to make sure, but the right still showed as open, eliminating a bad sensor, as it worked fine on the opposite side. I then traced the wires to the abs ecu and tested continuity all the way to the blue connector in the fender well. All is good. I even spliced the sensor right into the wiring just to be absolutely positive. The only thing I can think of now, is that the area the sensor reads in the hub may need a cleaning? Any help is appreciated.
 

·
Registered
Joined
·
6 Posts
Did you find / fix the problem my RR is doing exactly the same , have swapped sensors and same open circuit fault with the 3 amigos coming on EVERYTIME I drive after about 15 mins driving.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
No it's still having the issue. I've even ran new wires straight to the abs ecu to no avail. I've checked every connecting harness to the abs ecu and cleaned with electronic cleaner. The only thing I forgot to post earlier is that my all coms also tells me I have a can bus fault and intermittently a initial filling resevoir error when it reads the sir suspension. Some folks have said anything that may cause a can bus error could be a voltage problem that can throw a lot of things off, but I'm not sure. The dealer is an hour and a half away and budget is tighter than I like so I'll keep looking and trying new ideas as I come across them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I thought of that, so I purposely unplugged the left sensor and re checked. Both sensors open circuit at that point, so it's reading the left sensor (drivers side) correctly. I may just run a continuity and resistance test on the left side wiring to get a definitive answer though.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
I think I'm just going to have the abs module refurbished. I saw a few of the refurbish companies on eBay lately with a lot of good results. At least it'll rule that part out.
 
1 - 6 of 6 Posts
Top