RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
343 Posts
Discussion Starter #1
At first I thought I had a weep from the water pump but it looks to be coming from the engine where the pump mounts. Any idea what this is called? Or what I need to fix?

 

·
Premium Member
2002-2005 Range Rover MkIII / L322
Joined
·
3,622 Posts
A $3 jar of Barr's leak stop and call it a day. To fix it 'the right way' though I have no idea.
 

·
Registered
Joined
·
343 Posts
Discussion Starter #3
kmagnuss said:
A $3 jar of Barr's leak stop and call it a day. To fix it 'the right way' though I have no idea.
After some searching I think that may be the "front cover" gasket (pg 214 of Rave).
 

·
Administrator
Joined
·
27,841 Posts
It is indeed the front cover gasket. Some of the water pump bolts go through that to the block. Either a 10mm or 12mm wrench might fix the issue with a little nudge on the bolts.
 

·
Registered
Joined
·
343 Posts
Discussion Starter #5
rrtoadhall said:
It is indeed the front cover gasket. Some of the water pump bolts go through that to the block. Either a 10mm or 12mm wrench might fix the issue with a little nudge on the bolts.
Looks like a bugger to replace.
 

·
Administrator
Joined
·
27,841 Posts
Not at all. sump, addons, water pump and then it just unbolts. Since you are not replacing it there is no reason to remove the oil cooler lines etc. Also give you a great chance to clean things up. Depending on mileage it give you a change to press in a new front seal and/or change out your oil pump.
 
1 - 6 of 6 Posts
Top