RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter #1
Why is it important, and should I bother fixing the bolt that seems to be broke.....

 
G

·
Guest
Joined
·
0 Posts
Looks like the secondary air injection pump.
if it is, it's supposed to help with cold starting. Disconnect it and forget about it.
 

·
Registered
Joined
·
401 Posts
SAI pump, may throw a fault code if it doesn't work and if the sai pipes have holes it will sound like a tractor at start up.
 

·
Registered
Joined
·
127 Posts
Looks like the secondary air injection pump.
if it is, it's supposed to help with cold starting. Disconnect it and forget about it
I thought it was a NAS fitment and it helps lower emissions?? It may cause issues for you over there by removing it.

This is the beauty of forums however because i drive a diesel and live in England....
 
G

·
Guest
Joined
·
0 Posts
offroadbaz said:
Looks like the secondary air injection pump.
if it is, it's supposed to help with cold starting. Disconnect it and forget about it
I thought it was a NAS fitment and it helps lower emissions?? It may cause issues for you over there by removing it.

This is the beauty of forums however because i drive a diesel and live in England....
Mine was a NAS fitment, and it may have been emissions related. My state has no emission testing, so when the mount broke and it became noisy, I disconnected it. I thought it was to aid in cold starting myself, but I never had any issues starting in very cold temperatures.
I did have a CEL though. I had it before and after and it was just because of the MAF.
Disconnect it.
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
it's to reduce emissions on cold startup, has nothing much to do with running, just trying to make the environmentals happy....
 
1 - 7 of 7 Posts
Top