Range Rovers Forum banner
1 - 6 of 6 Posts

·
Registered
2008 Range Rover Vogue Luxury TDV8
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi there. New owner to an immaculate 2008 Range Rover Vogue TDV8. Runs like a dream but I noticed this loose cable at the rear driver's side wheel arch. I thought it might have been a rear parking sensor cable that had come loose but the sensors seem to be working fine. Cannot get into the spot where the connection should be and for the life of me can't find anything online that resembles it. Would appreciate any help from owners out there that might know.
Cheers,
KW
IMG_2013.jpg
 

·
Registered
L322 - 2005, 2006 na, 2012 sc
Joined
·
356 Posts
This is the rear right corner, correct? That is where the EAS valve is for the rear, behind the arch liner. Does your truck still have functioning air suspension?
 

·
Registered
L322 - 2005, 2006 na, 2012 sc
Joined
·
356 Posts
Good call. I'm guessing that's it. As I recall, each of the TPMS sensor leads had a short length of plastic sheathing like shown in the picture and the sensor attaches to the back side of the wheel arch liner.
 

·
Registered
2008 Range Rover Vogue Luxury TDV8
Joined
·
3 Posts
Discussion Starter · #5 ·
This is the rear right corner, correct? That is where the EAS valve is for the rear, behind the arch liner. Does your truck still have functioning air suspension?
Yes the air suspension is still working fine as far as I can tell. All four points are raising and lowering as expected.
 

·
Registered
2008 Range Rover Vogue Luxury TDV8
Joined
·
3 Posts
Discussion Starter · #6 ·
Thanks for the responses guys. It does look like TPMS so I'll take a closer look.
 
1 - 6 of 6 Posts
Top