Range Rovers Forum banner
1 - 2 of 2 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
58 Posts
Discussion Starter · #1 ·
Weird Fault, after battery change - Over fueling,no tick over on start up.

Hi Guys need your help again.
Car was running perfect on Petrol & LPG until Last week, car would sometimes start , sometimes nothing. I thought it was the old battery that was knackered, so put a new one in, still same problem then i traced fault to an arcing spark/loose connection at the starter motor.
sorted that out and SHE fired up first time,so battery and starter motor is now fine, but it ran awfull, with smell of fuel and blue smoke from exhaust, managed to coax it to life through the throttle pedal, (it defo isnt firing on all cylinders and wont tick over but managed to get it to switch over onto gas (lpg) at 2000 rpm and ran sweet on a 220 mile trip home.
Im sure its an electrical gremlin somewhere any ideas guys. the battery was disconnected for approx 24 hrs until i got the new one in.

thanks Andy
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
58 Posts
Discussion Starter · #2 ·
Re: Weird Fault, after battery change - Over fueling,no tick over on start up.

Update ! i think its fixed.
Cleaned the MAF Sensor and the sensor connected to the air filter, left hand side oxygen sensor wire block connection on exhaust with CRC SPRAY,
And hey presto ! now idles spot on,runs on all cylinders, no blue smoke from exhaust and dosnt stall.
Fingers crossed my problems are now solved ,till next time lol
 
1 - 2 of 2 Posts
Top