RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
Is this normal on a 4.2 sc ? As soon as i start it it’s on full speed however after a couple of minutes it quietens to normal?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #3
Could you do me a favour - could you put your key in position 2 (lights on dash) but don’t start and see if you here an electrical buzz from the front of the car (s/c coolant pump) trying to work out of it should buzz or sound more of a pump whir.. cheers
 

·
Registered
Joined
·
596 Posts
I don’t think I’ve ever had a vehicle that didn’t do that. Except maybe the 87 Cadillac because it had the transverse engine with only an electric fan.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
296 Posts
Is this normal on a 4.2 sc ? As soon as i start it it’s on full speed however after a couple of minutes it quietens to normal?
It’s normal
Mine does this even under -30c
I live in hard climate conditions
We choose in summer times on sdd configurations, vehicle for warm climate, in winter vehicle for cold climate

Under -20c range rover works on odle 1100rpm to charge battery
If you dont chose cold climate configurations its work 910rpm
 

·
Registered
Joined
·
131 Posts
If you think the fan is loud on a L322, you should hear the start-up roar on a P38. It is perfectly normal at start up. If you don't hear it, you have a VC going bad. It takes a few rotations for the fluid to circulate.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #7
Hi guys -

I still not sure it’s the same - it is loud for theentire time the engine is on double injector cycles during the warmup plus another minute or so - is that normal?

I have a bmw engined 4.4 vogue as well and it doesn’t nothing like this at all - also have a v10 m6 nothing like this fan wise either...
 
1 - 7 of 7 Posts
Top