RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Picked up a iCarsoft i930 after having my check engine light pop on yesterday on a short drive. Plugged it in and had code P2098 show up "Post Catalyst Fuel Trim System. Too Lean Bank 2". I erased the code started the car up and ran the ac for about 5 min while in park. While sitting there the car out of no where jumped forward?

Not sure what the cause of this was so I'm wondering if anyone can give any insight here.

Was the computer resetting itself perhaps? I've never had this happen but after having the oil changed last week I spoke with my independent LR mechanic about the tranny lurching a bit when downshifting while coming up to stop signs (not nearly as violent). He said it was the programming in the ecu and was common in both LR and BMW.

I should say the battery somehow was disconnected during the service. I've driven probably 100 miles since and no other lights/codes have come up. Am I still in the adaptation phase maybe?

Should I drive around locally and see if any codes come up?
 

·
Registered
Joined
·
631 Posts
Waiting for other people to chime in, but if your vehicle is sitting in park, and it jumps forward, that can only be a tranny issue.

Have you had any transmission problems? Are you leaving out some details?

What year and model is your truck?

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
The previous owner replaced the transmission pan because there was a leak. I've not had any issues in 8,000 miles.

It's an '06 HSE 4.4 with about 83k.

I cleaned the throttle body and air filter this morning. Drove around a bit and it's still shooting the same P2098 code.

Called around and most aren't familiar with the code. My tech is a bit busy but he's saying maybe leak in the intake or faulty o2 sensor.

Wondering if I should take it in or keep driving it hmm...
 
1 - 3 of 3 Posts
Top