RangeRovers.net Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Okay my new to me 2014 RRS just went on the blink and started throwing faults at me about 2-3 weeks ago. Initially car showed me a Suspension fault but would clear it on restart after a few mins. Happened twice initially over a period of a few days but now car will NOT clear any faults and I am getting the following:
  • Adaptive Dynamics Fault
  • HDC Not Available System Fault
  • ABS Fault
  • Camera System Fault
  • Stability Control Not Available Fault
  • E-Diff Not Available
  • Suspension Fault
  • EBD Fault/Emergency Brake Assist Not Available
  • Gearbox Fault
Will have vehicle towed to dealership on Monday and have appt set up for Tue AM on 7/26 and a loaner but what gives? Car was perfect up until now. Had an OEM tow hitch installed last month and towed a Uhaul 5x8 trailer to my new home and other than the car throwing a rear blind spot sensor fault while towing nothing else has occurred till this. Had a Escort Radar detector hardwired to the car for my Escort MAX 360 last month but that shouldn't cause this as it hasn't with any other of my cars which I had hardwired. So am at a loss...WTH... :( Anybody seen similar or thoughts?
 

Attachments

·
Registered
Joined
·
55 Posts
Discussion Starter #3
Where is it located? Oh found it searching the forums..under the rear spare. Since car is pre-owned not sure if its the original one or not. Curious tho as vehicle starts okay and I've gotten no low voltage alerts or problems cranking so not sure how low voltage could be an issue. I do have a full size battery charger...should I throw it on there?
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
I've heard these cars throw a ton of faults due to low voltage. Check your battery, maybe you need a new one.
Replaced battery with brand new one this AM. No joy..still same faults. :( But it looks like the battery was the original one the came with the vehicle (it was stamped 4/14) so it's been in the car a while. End result..vehicle is at the dealership now with their techs and hopefully the culprit will be found and fixed soon. Have a nice '17 Discovery Sport as a loaner...nice vehicle.
 

Attachments

·
Registered
Joined
·
55 Posts
Discussion Starter #5
Got the RRS back this AM and its up and running great so far.

So...the dealer had it for a week almost 5 days to be exact and found issues with the fuse box. No communication with the ABS, PSM, CHCM modules, and low/no voltage in the BJB along with a relay without voltage. Fuse was also blown at F6 in the CJB. They then traced wiring and found chaffed wiring under the BJB. Repaired this and replace the entire fuse box assembly. Then performed a multi-point inspection including suspension and topped off all fluid levels. So we'll see how it goes but thanks to Land Rover of Omaha for their excellent service to include the loaner vehicle.
 

·
Registered
Joined
·
132 Posts
Ah nice. Where I live, we have to wait for 2 weeks for a appt and forget loaner.. For those 2-week-noloaner appointment, I'm being told they might keep the car upto a week.. This is for some just regular maintenance.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
1,075 Posts
Glad you got it all squared away. Sounds like you have a great dealer too!
 

·
Registered
Joined
·
55 Posts
Discussion Starter #8
Ah nice. Where I live, we have to wait for 2 weeks for a appt and forget loaner.. For those 2-week-noloaner appointment, I'm being told they might keep the car upto a week.. This is for some just regular maintenance.
Glad you got it all squared away. Sounds like you have a great dealer too!
Yep...they seem to be on point and I didn't even get the car from them. Am new to the area (military and just transfered here when the car crapped out on me); but car was purchased in Cali and shipped to me in AZ then I drove it here so they have no loyalty or history with me or the vehicle so yeah I am pleasantly surprised at both the loaner and how quickly they got it fixed and the cost (covered under warranty except for a $21 part)! I've heard some of the stories you guys have posted about dealer service and also history of Land Rover's being always in the shop and having delays for weeks for parts and was one of the things that made me hesitate on this car. But I went with my heart and purchased it and so far so good...am very satisfied with it.
 

·
Registered
Joined
·
75 Posts
Low voltage strikes again! May not have been the battery that was at fault but so many components to these systems. Glad you got it sorted.
 

·
Registered
Joined
·
1,089 Posts
2015.5 Autobiography here. 18744 miles on it and this just happened to me Friday night stranding me. I couldn't get it out of park. I was blocking the roadway too. I'd start it try to shift into Neutral or Drive and it go to park and warn me it would shut down in 3 minutes but shut down immediately after. It was flat-bedded to dealer and waiting to hear whats up. Took 3.5 hrs to get a truck after calling roadside assistance. Another hour to get it on the truck... frustrating.
 

·
Registered
Joined
·
1,089 Posts
Update: Alternator needs to replaced as well as battery. Then they will see what else needs fixing after they can have the car running again. No problem its all warrantied.
 

·
Registered
Joined
·
1,089 Posts
Update: 2 days in. Dealer asked to drive around see if any of the faults come back. So far looks good. New battery and new Alternator solved the issues. Nothing has showed back up. They also did two campaigns (software updates) and said they thought that was only issue but wanted to see if some other faults came back. Great! No faults motoring on.

I have nearly 19,000 miles and apparently am second 2015 RRS with to come back in with a failed alternator. I asked about electriacl shorts since I have accessories and I did tap a fuse for camera, they said not a problem. Might be coincidence other 2015 with bad alternator was also low miles like me. The bad alteernator over drained the battery. Funny I didn't get any warnings and after it showed me charging system failure car barely made it 1/2 mile before it was undrivable shut down and would not start. Youd think the backup start/ stop battery would be utilized but thats not so.
 

·
Registered
Joined
·
1 Posts
Okay my new to me 2014 RRS just went on the blink and started throwing faults at me about 2-3 weeks ago. Initially car showed me a Suspension fault but would clear it on restart after a few mins. Happened twice initially over a period of a few days but now car will NOT clear any faults and I am getting the following:
  • Adaptive Dynamics Fault
  • HDC Not Available System Fault
  • ABS Fault
  • Camera System Fault
  • Stability Control Not Available Fault
  • E-Diff Not Available
  • Suspension Fault
  • EBD Fault/Emergency Brake Assist Not Available
  • Gearbox Fault
Will have vehicle towed to dealership on Monday and have appt set up for Tue AM on 7/26 and a loaner but what gives? Car was perfect up until now. Had an OEM tow hitch installed last month and towed a Uhaul 5x8 trailer to my new home and other than the car throwing a rear blind spot sensor fault while towing nothing else has occurred till this. Had a Escort Radar detector hardwired to the car for my Escort MAX 360 last month but that shouldn't cause this as it hasn't with any other of my cars which I had hardwired. So am at a loss...WTH... :( Anybody seen similar or thoughts?

283862
I had the EXACT same fault. Note that nothing was actually wrong as Land Rover has stated, it’s this 10A Fuse located in the boot/trunk of the car.
 
1 - 13 of 13 Posts
Top