RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1
Recently I have encountered two problems with my sport.

1. Radio trim piece (the fast forward button) had one of the clips snap, the dealer is claiming it is a trim piece and therefore not covered under warranty. Fair enough. But they say the only way to fix this .02 cent piece is to replace the radio head unit 8-0= is this really the case? If so I will just use the steering wheel button.

2. In the past several weeks I have done two 100 mile road trips and at the end of the drive as I pull off of the freeway and do my last dozen or so blocks of street driving I noticed my engine temp gauge to only be half as warm as it should be (if we consider the normal position to be horizontal) confusing but I am sure umbertob can visualize this. Anyways along with the engine temp being on the cool side the fan kicks in like you would notice when you start the engine in the morning and start driving before it warms up. I am wondering how serious of an issue this might be and would like to be armed with a possible diagnosis before going to the dealership. Any thoughts?

I attached a picture taken on that same road trip about 15 minutes before the issue arose as I pulled over at a rest stop to take a picture of the mileage, you will notice that the engine temp is normal at this time.

 

·
SUPER MODERATOR
2006-2009 Range Rover Sport
Joined
·
4,469 Posts
Milo,

There was another fellow about 3-4 weeks ago who had the same issue with the fan, believe they replaced a few of the parts, including the thermostat and a couple of other items I can't remember at the moment.

Should be an easy fix though....
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
I think it was RoverfreakNH if you want to do a search.

He's had every part but the headliner replaced under warranty in his car :D

If you're out of warranty, check the thermostat first Milo.
 
1 - 3 of 3 Posts
Top