RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
2013-2015 Range Rover Sport
Joined
·
106 Posts
Discussion Starter #1
Got a bit of a mystery with my '13 RRS SC. Bought her last year and she had a set of Glohh tail lights already installed. Worked 4.0 for the entire time we have been a couple but when I went to have the annual safety inspection done, the turn signals on both sides were inop. They work on the front, sides, and IC. Hazards demonstrate the same functionality as well. Checked the fuses and both were fine, at least, what I believe to be the turn signal fuses as the symbols are sort of ambiguous. I pulled both lights and the area is dusty but dry, so no water incursion there. Running and brake lights both work as advertised.

In my research I have yet to find the location of the turn signal relays, if this mythical beast even exists on newer RR's. Even more confusing is that when I checked them this morning, I noticed on the left side, the turn signal lights were coming on, but very dimly. Further, on the upper outside quadrant of the tail light is a bank of 3 LED's and the ones on the right turn signal were operational but not on the left. I contacted Glohh but they have not yet responded. It would seem odd that both lights lost their turn signals simultaneously but it probably is not unheard of.

Any thoughts from all you Fine, Young Cannibals out there??? Appreciate the inputs.

GL-3-01.jpg
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
128 Posts
I have a 2012 wiring diagram that shows its not relays but 2 FETs. C0583L-37 for rear left and C0585L-9 for rear right. Both located the central junction box (P101). I'm not sure, but that may be the one that you get to by dropping the lower passenger-side glove box. (just open it and push on the front of both retaining arms at the top).

I'd post the wiring diagram here if I could figure out a way of attaching it. but the attachment button seems to just bring up a blank window.
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
106 Posts
Discussion Starter #3
Thanks. I will be doing some trouble-shooting this weekend and will give that a look.

The Central Junction Box is indeed behind the glove box. Those British types seem somewhat averse to the use of 'fuse box'...
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
106 Posts
Discussion Starter #4
Niz,

Does your wiring diagram show where the FETs are located on the CJB?
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
128 Posts
Nope.

The numbers I already gave above look like junction box connector/pin designations: Left: C0585L-9 Right: C0585L-10 (sorry, looking again I think the C0583L-37 number I gave above is actually for the front right indicator).

Above the wiring before the connector are the following numbers: Left: GR,1.5D,5865 Right: GW,1.5D,4875 Presumably GR and GW are wire colours (green and green/white?) and the numbers are the harness codes, but just a guess.
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
51 Posts
Not sure, never had a problem with my glohhs but i did have an issues with led side markers that were bugging my whole system. Did you replace those as well? If so id start there. Good luck!
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
106 Posts
Discussion Starter #7
Update to this saga:

-Mapped the pins to the function on the tail lights except for pin #3 which I believe is to the actual turn indicator but believe that it requires two pins to be active (3 & 6).
-Pin #1 is to the brakes and constant 7v
-Pin #2 is reverse and the wire is Gn/Bn vice just Gn
-Pin #3 is a constant 7v
-Pin #4 is running lights and constant 12v
-Pin #5 is ground
-Pin #6 activates a series of 3 LED's next to the reverse lights (on the Glohh system)

Right running lights were working but now the whole right side (ft/r) are inop. Brakes still work as does reverse.

I am now out of airspeed and ideas so I will be taking it to a local indy that does RR's.

Wish me luck, I'm going in...
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
106 Posts
Discussion Starter #8
Well, after getting my RRS back from the Indy, I came away with this:

-The BCM is grounding out on the rear turn signal output
-The left rear Glohh tail light turn signal is DOA

After much contemplation and the complete lack of help from Glohh, I by-passed the BCM and wired the rear turn signals to the side repeaters. I also took the lense covers off of the housing and put new LED's in place of the installed ones (they are still there, just turned back into the housing).

I will add that the factory in China that Glohh has these made needs some serious auditing of their QA and assembly line. The workmanship inside these $1,000 pieces of plastic is horrendous. Silicon glue placement was sparse at best and should be covering the wiring connections, the internal wiring was poorly laid out and the plastic internals were cheap and several parts were broken. It really is disheartening to find that such expensive items are so cheaply made. Coming from a company who caters to Range Rover exclusively, you would like to believe that they make a product that is of quality parts and workmanship and that it would last longer than a year. I am sorely disappointed in Glohh. But on the bright side, my truck passed inspection!
 
1 - 8 of 8 Posts
Top