RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Transmission - upshifts under normal driving conditions. P38.

My trans randomly upshifts after it gets warm - it will shift from 4th (while cruising even) to third and even second at almost any speed. I also cannot engage "MANUAL" mode on the trans (4.0 SE) - it will go into sport mode, however, the diagnostic system says "transmission fault" when coming to a stop usually - this then kicks it out of SPORT and I cannot reenter SPORT mode until the vehicle is stopped and restarted. Any suggestions? I switched the TPS from my other rover which worked & the problem is still the same. The transmissions shifts themselves are not jerky - they are perfectly healthy. Any input would be greatly appreciated - I'm personally leaning towards a TCU but honestly I'd prefer to hear from someone who knows more about these types of issues.
Thanks,
John
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
690 Posts
Re: Transmission - upshifts under normal driving conditions. P38.

It's manual in low range, sport in high range.

Have you gone through the electrical sticky? Weirdass "GEARBOX FAULT" messages are strongly correlated with crappy bus voltage.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
Re: Transmission - upshifts under normal driving conditions. P38.

Thanks - I've not looked at that sticky but a number of other posts that talk about - I figure I should going to check the battery & might as well switch the alternator from my parts GEMS which I know is stong/good.
This link popped up which correlates with my issue: http://forum.lro.com/viewtopic.php?f...53c86&start=10
I
am also flagging a CAS fault on the scanner so it is likely an issue with the CAS plug - thanks for the input I'll for sure check out that sticky.
 

·
Banned
1995-2002 Range Rover P38A
Joined
·
3,952 Posts
Re: Transmission - upshifts under normal driving conditions. P38.

As I said on your other thread, what's a CAS error?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
Re: Transmission - upshifts under normal driving conditions. P38.

Sorry - I missed that, it's for the Cam Angle Sensor or camshaft positioning sensor I think they call it on the Rovers. The error codes were the following:
P0340 - (Signal open & short circuit to vehicle supply or ground). - this seems to relate to the MAS in other forums I have found while it relates to the CAS in RAVE.
P1775 - Gearbox has signaled a fault condition.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Re: Transmission - upshifts under normal driving conditions. P38.

Thanks all - solved the issue by cleaning the electrical connector suggested by the LRO forum and Gilbertd - it was a surprisingly easy and cheap fix for such an annoying problem.
 
1 - 6 of 6 Posts
Top