RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Let me first say I'm New to the forum and have searched but couldn't find anything similar to my problem, hopefully someone can help!

I have a 04 L322 In the USA with 145k miles. I'm having some sort of problem with the transmission and would like to get your opinions on what it could be.

When it is cold it will shift smoothly thru all the gears and no problems.

When I'm trying to merge onto the interstate or to pass someone instead of the transmission downshifting, all that happens is the Engine RPM'S go up and there is a loud screeching noise until I let of the throttle and than it just bangs into a gear.

When I switch to manual mode it still happens but not as much.

I have done a trans flush and no changes. I bought it used and have put less than 1000 miles on it and the problem started.

Thank you in advance for the help!
 

·
Registered
Joined
·
1,758 Posts
The life span of the trans before a rebuild is required is generally maxed at 129 k miles so yours likely spent a lif if time in the highway in top gear. Ours went at 120k miles read posts by rrphil on this site and you will very likely match your symptoms to determine the main issue which is often a small flat roller bearing failure that precipitates your issue. Same as ours and ours had several things wrong inside. We still gig the sheet metal sound after the rebuild but it was less noticeable. I am one of many with this failure and a plugged trans cooler on the water side did not do it any favours. Pm if you care to.
 
1 - 2 of 2 Posts
Top