RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi everyone
ive been reading your posts and other peoples now for a number of weeks,your answers and knowledge is brilliant and am hoping for that to be used on my problem the story so far is
,my range rover sport 55plate has been juddering,lack of power,and rising rpms,
i sent it to a auto tranmission specialist they confirmed it needs torque convertor,i have now had that fitted with reset und update,new fluid,filter,but less than 6miles down road after pick up the juddering starts again but very mild,rising rpms again,and fault code limited gears,the faults are po500-00 vehicle speed sensor a,po783-62 signal compare failure,po783-64 signal pausibility fauilure,uo155-87 lost comminuication?have you got any ideas for what it could be pleaee?4 diffrent garages have had a go now and no better,the noise is slowly getting worse,could it be new torque convertor is faulty?its the same sort of symptons as previously before torque converter replacment but just very mild,when upto 60-70mph its fine,also symptons seem as if its when gearbox oil etc gets up to working temprature,all gear changes are fine just juddery they find the gears fine thanks again and i hope you respond thanks so much

kind regards

louis
 

·
Registered
Joined
·
358 Posts
If the speed sensor is not giving the transmission the right info - this could be part of your problem. I would start with that and check the wiring harness and connnectors. Need to find someone who has expertise with the zf box ....
 
1 - 2 of 2 Posts
Top