RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
IS there a good wiring diagram for the trailer harness? truck has the OEM or dealer add on harness with the black box behind the RH taillight. has the 7pin round connector with the 7-4 flat adapter.

trying to get it to work...
 

·
Registered
Joined
·
97 Posts
Discussion Starter #2
ok, found a red wire unhooked that went into the box, applied 12v and the lights work.

where can I find a constant 12v input at the back of the car?
 

·
Registered
Joined
·
401 Posts
where did you get it? did you have to put a set of wires into a white plastic molex connector?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #4
rhino_ed said:
where did you get it? did you have to put a set of wires into a white plastic molex connector?
came in the car. has the white connector on it. it is a factory looking or dealer add on looking deal. not spliced in.
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
KyleT said:
ok, found a red wire unhooked that went into the box, applied 12v and the lights work.

where can I find a constant 12v input at the back of the car?
you may have a blown fuse, you should only need to plug it in. Also, don't leave it plugged in, or the EAS will stay in std height and not raise/lower (for towing safety....)
 

·
Registered
Joined
·
21 Posts
I ran into a similar issue this week. I went to pull a Uhaul trailer and could not find an adapter. I went to a trailer place that installs hitches and they spliced into the wires and installed standard four flat plug. The wire sits in the area near the sub woofer, I just run it out the back when I need it. Took them about 30 minutes and cost $50.
 

·
Registered
Joined
·
541 Posts
The kit I have from AB just plugs inline into the factory harness back in that little cubbyhole behind the RH rear light. If yours is similar and it is not working unless you apply 12v externally, you may have a bad converter box although usually when they go, you'll still have lights on one side or the other of the trailer. I agree, check the fuse, you need to figure out why you don't have power to it if the fuse is ok. You shouldn't need to find another power source.....
 
1 - 7 of 7 Posts
Top