RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Well I tried searching this topic but still need some help. I have an '06 HSE and it includes the factory supplied wiring. So I connect the trailer up and all the lights work but brakes do not activate. Dealer seems kind of clueless. So: Where is the best place to buy the controller? Anyone know of a good installer in greater metro NY? I would DIY but only if there are some really idiot proof instructions someplace. TIA as always.
 

·
Registered
Joined
·
7 Posts
http://www.rangerovers.net/outfitting/t ... ntrol.html

pretty fool proof. The only thing I had to do different, is on the 2006-9 trailer wiring, the blue brake line (from the trailer wiring harness kit) was run into one of the two connectors, but still doesn't connect to anything. You need to cut it loose in order to connect it to the line you run from the brake controler. Other then that and routing the power and ground a little differently, I did it just this way.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
That's a beautiful thing, thanks. Did you disconnect the battery while doing the job? If yes, any error messages when you reconnected?
 

·
Registered
Joined
·
7 Posts
Actually, that's the one thing I haven't done, I ran out of time. All the wiring is done and in place including the circuit beaker and the wire to the battery. I just have not wired the positive lead into the battery, though the way I want to do it should not require disconnecting the battery. In theory. That's a project for next weekend, I want to get a cover for the circuit breaker to keep any accidental shorts from happening before I wire up the hot lead.
 
1 - 4 of 4 Posts
Top