RangeRovers.net Forum banner

1 - 1 of 1 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
11 Posts
Discussion Starter #1
Tilt Telescopic Memory Seat question again, dont shoot me I have searched!

Hello,

So I have the same issue as quite a few folks on the forum. No Tilt Telescopic or memory functions. I searched the forum and found some good starting places and this is what i have done and the results.

2003 HSE 4.4
Motor will not make any noise at all.
Memory light will iluminate, and will set a seat position, but will not move seat to that position if I adjust it then hit the memory button.
Fuse is good.

After reading many posts on this, I read that a possible issue is in the lumbar switch. I unplugged the switch from the harness and still no noise from the motor at all.

I then started methodically unplugging all switches individually and listening to the column for any noise and nothing. I tried unplugging individual motors under the drivers seat and testing, and no noise.

I did read that there was a plug high in the drivers seat back that sometimes comes unplugged from years of reclinning and back up, so i removed the bottom edge of the seat and cannot figure out how the seat back bottom comes apart to apparently reach up into the back and feel if the plug is attached, or unplug it and reinsert it to to test, no joy on finding how to dis assemble the seat on the forum, or I didnt type my search correctly, which is more likely.

If the motor would make any noise, i think i could figure that one out, as most likely the motor mounts would be broken.

I checked the fuse each time as well, and it is good.

From my searches, i believe my issue could very well be the plug in the back of the seat, unless another expert in this field has another direction or something else to check.

Any help would be greatly appreciated! Many Thanks in advance!
 
1 - 1 of 1 Posts
Top