RangeRovers.net Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter #1
I did a search but couldn't find this issue.

2008 RRS HSE (4.4L Petrol) 68,000 mi.
This has happened twice in the past month. After slowing down to about 2-3 mph and then applying 1/3 to half throttle, the engine does not react. There is no rpm increase and no throttle response. It's as if I wasn't applying any throttle. I had to lift off the gas pedal and press it back down again. The second time it responded normally.

I hooked up the IID Gap Tool and scanned for any codes. There were engine misfire codes but nothing from TCM or anything I could see relating to Throttle.

Any ideas?
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
Has the transmission actually dropped to 1st gear when this happens or is it still coasting in second gear?
 

·
Registered
Joined
·
56 Posts
Discussion Starter #3 (Edited by Moderator)
I don’t know what gear it was in when I tried to apply throttle. On both times it happened, when I released and reapplied the throttle, it felt like it was already in 1st and I did not notice any kickdown from 2nd to 1st.

Are you thinking TCM software update needed?
My IID tool shows there are ECU updates available for my TCM and Transfercase but I have not tried to update them.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #4
RRToadHall,
I drove around today trying to replicate the issue. The transmission does appear to still be in 2nd gear when I get no throttle response..
That being said, what might the solution be?

Thanks..
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
I would venture a guess that the transmission ECU is wanting to shift to first going that slow when you apply the throttle. Are you only applying gradual throttle like in stop and go traffic or are you romping on it like rolling through a stop sign?

Did purchase this car preowned? If so the stored adaptive values may be adjusting to your style of driving vs the previous owner.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #6 (Edited by Moderator)
I am giving 1/3 to half throttle. Similar situation as rolling through a stop sign. Basically it occurs when slowing to stop at a red light but the light turns green before I need to come to a full stop. It also occurred when I was slowing down to yield to cross traffic and at the last minute realized cross traffic was not a factor so I give it 1/3 to half throttle to scoot across the intersection.

In the same situations if I lightly apply throttle then it will accelerate (probably in second gear.)

I did buy the vehicle pre owned but have since reset Engine and Trans Adaptations a few months ago after doing the Trans Service and an Induction Service.

I am just finishing up doing a Throttle Body/ MAF service and will be resetting the Engine Adaptations prior to starting it.

On a side note, The IID GAP Tool shows that there are ECU updates for my Transfer Case as well as Transmission. I am not sure if the IID tool contains those updates which I can apply or if I need to buy the updates from GAP. I contacted them but they didn't give me a direct answer as to whether the updates are already in the tool.

Thanks RRToadHall
 

·
Premium Member
Joined
·
516 Posts
As long as you update the tool via a PC you should have the proper updates.
 

·
Registered
Joined
·
231 Posts
I updated my transmission software on my 06 with the IIDtool (4 years ago - check with Gap for price) , but I had to purchase the actual updated transmission software through Gap, then update my Gap IIDtool, then upload/write it to my TCU on the rover. The new software works great.
So just keeping your GAP software up to date doesn't mean you get the other updated software unless you purchase it.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #10
I updated my transmission software on my 06 with the IIDtool (4 years ago - check with Gap for price) , but I had to purchase the actual updated transmission software through Gap, then update my Gap IIDtool, then upload/write it to my TCU on the rover. The new software works great.
So just keeping your GAP software up to date doesn't mean you get the other updated software unless you purchase it.
Thanks,
I’ve contacted GAP and will purchase the update for my Transfer Case first, then I’ll get the transmission update.
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
I contacted them but they didn't give me a direct answer as to whether the updates are already in the tool.
Actually you asked about new firmware and beta firmware, not if a particular update was in your tool's current firmware version. Perhaps you can clarify what exactly you are wanting with Patrick via PM.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #12
I originally contacted them about my tool showing available updates and didn’t know what those updates addressed or how to access them. Recently I wanted to see if there were any newer FW builds for the tool or Beta FW’s. A lot of my confusion was coming from comments stating that the tool contains updated ECU files. I heard about Beta versions and additional features thinking that is what I needed to have all the latest ECU files and features in the tool.

Patrick has since cleared it up as of this morning. Now I understand what is and what isn’t available within the tool itself. Sorry if I jumped around on asking different questions. Blame it on my ADD :)
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
LMAO.... No sweat, I was reading back and forth between threads. The folks over at GAP are always good about clarifications and and explaining things. :thumb:
 

·
Registered
Joined
·
56 Posts
Discussion Starter #14
Purchased and installed the Transfer Case and Transmission updates from GAP. Now time to put some miles on it.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #15
Transmission ECU update solved the throttle delay issue.
thanks to Patrick at Gap Diagnostics and RRToadHall for steering me in the right direction.
 
1 - 15 of 15 Posts
Top