RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all newbie here .

bought a 2003 L322 TD6 3.0 Diesel . over the internet without seeing it ( stupid )
father in law went to pick it up and broke down on the way home . fuel problem . AA came out and said its the High pressure punp , anyway got it home and diagnosed it , bought a low pressure pump job sorted , it was only the bloody fuse that had blown lol .
now i have found the electric front seats do not work nor does the steering rake adjustment , also the drivers side window switch module as been removed , are these all connected together ? also the fuse box cover is not therein the glove box so i do not know what fuse is what , i have looked at loads of posts but can not seem to find the help i need , drove it today about 5 mile and it seems to me to rev high before changing gear , is this normal ,

thank you in advance if you are able to point me in the right direction ,
 

·
Registered
Joined
·
385 Posts
Fuses don't blow unless something went wrong to cause it to draw excessive current. It could have been due to troubleshooting error.

The fact that you're missing the fuse cover and a window switch, my guess is that someone was on the hunt for an electrical gremlin and left destruction in his wake.

The shifting issue could be related to electrical problems, as well, but without much more details it's impossible to say what's going on.

Do you plan on working on the vehicle yourself?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Fuses don't blow unless something went wrong to cause it to draw excessive current. It could have been due to troubleshooting error.

The fact that you're missing the fuse cover and a window switch, my guess is that someone was on the hunt for an electrical gremlin and left destruction in his wake.

The shifting issue could be related to electrical problems, as well, but without much more details it's impossible to say what's going on.

Do you plan on working on the vehicle yourself?
Hi wayne
yes i try to do most work on them myself .
the fuse box is also loose so someone as been busy , now cannot drive the RR , more error codes , i do not know why i bought another RR i have had 4 over the years , all trouble from the classic upwards .
.
put a new H/O battery on as it had the wrong battery on .
now it will not engage drive .
Diagnostics says
1 Torque converter clutch solenoid
2 lane pressure solenoid 2 3 5
3 A shift solenoid
4 E shift solenoid
5 shift solenoid C
also have noticed that both front seat the electrics do not work nor does the the steering adjustment , have checked all fuses they are fine . i am waiting on a new drivers door module would this affect the seats ?

cheers all
 
1 - 3 of 3 Posts
Top