RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,
I have a 2006 L322 with the s/c Jaguar engine. The keyfob stopped working for remote unlock/lock so I followed the reset instructions below :

) Get in and close all doors. Turn ignition on and off quickly and remove the key (all within about 5 seconds).

2) Within 30 seconds of turning the ignition off, while holding down the "unlock" button, press the "lock" button three times. Release the "unlock" button. (You may or may not get the confirmation from the door locks.) Holding the key at your head level provides best results as the key sensor is in the side window pillar.

3) Repeat for each key you want to initialize within 30 seconds after the last one you initialized (if you have more).

4) Right after doing the last key, quickly put the key back in the ignition and turn it on/off again to finalize
.

After a few attempts, it worked and I was as pleased as punch but after a few days it stopped and no matter how hard I try, I cannot get it to work again using the notes above. I have replaced the battery in the key and cleared all faults in the car but it still wont work - everything else seems to be fine.
Does anyone have any ideas please.
Before I get told off, I have searched the forum for quite a while but cannot find any other solution.
Thank you in advance for any help.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
494 Posts
I had a similar problem with my 03 BMW built MkIII and did as you did and nothing... Then I disconnected the battery and shorted the pos/neg (do not do this with the battery connected) for 30 to 45 seconds. Reconnected it and all programming worked. Not sure why it failed but after I cleared all faults with RSW reader it was just like you and could not reset the keys. After the battery disconnect negative short procedure it worked.

Note you will have to reprogram your on board display as well as re set your clock etc.

Good luck.
 
1 - 2 of 2 Posts
Top