RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
4 Posts
Discussion Starter #1
Hello to all of you , i would like to have the expertise and a little help about the problem i have on my Range Rover FF L322 TDV8 3.6L Year 2007
Let me expain a bit the history of the car

I bought the car in Italy ( Im from France ) quite cheap ( 4000 euros ) from a dealer because the car had 250 000 kms and a major oil leak that was actually coming from the left rocker cover that was cracked and a problem with the gearbox , the rpm was boucing ,the gear change was a bit erratic and sometime on load i had a bit of a shudder coming from there.

So after changing the rocker cover i decided to buy a used gearbox on ebay with the torque converter included and to swap the gearbox and TC on the car
On the used gearbox i have changed the squared rubber gaskets, the 4 round rubber gasket for the mechtronic , changed the oil and the filter, reset the adaptations and a learning procedure using SDD.

For the last 15 000kms the gearbox was working quite good but now i have a problem that i would like to have any advise from you guys
let me explain it the best i can:

The problem is not present all the time, usually not present when the engine/gearbox are cold
What is happening is during normal driving usually when you lift off the throttle the RPM will stay around 1000+ RPM for the downshift to be smooth but in my case sometimes the RPM will drop to IDLE around 700/800 RPM and when the downshift happen it will be very very harsh ( mostly for the 3-2 and the 2-1 )

So what i have tried to do is to buy some refurbished solenoid and changed them to see if any change but its the same
For the past 3000 kms i had 3 times the P0741 code " Torque Converter Clutch Circuit Performance or Stuck Off " stored in the tcm usually after a transmission fault display on the dash.
I dont really know if its coming from an internal problem in the mechatronic ( pressure lost ), a torque converter or TC clutch problem, TCM problem or if its engine management related as when the rpms are not dropping everything is fine

Every help would be appreciated

Thanks to everyone
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
4 Posts
Discussion Starter #3
A quick update ,, this morning for most of my travel to work i had the problem most of the time.
When i arrived to work i have scanned the car and i had only the P0155(87) code which means Databus Instrument cluster module no communication, could be related to my problem i think but what can be the problem with the module ? Wiring ? Module itself ? the cluster ?
 
1 - 3 of 3 Posts
Top