RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi everyone, tail lights not working bulbs ok, connections ok, there is no fuse to change according to manual, any suggestions thanks.
 

·
Premium Member
Joined
·
1,345 Posts
Check the ground connections and whether you actually get 12V at the bulb holders. Do indicators and brake lights still work? Do you get the warning message?
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
771 Posts
Check connections around the becm, especially the back ones as they can get knocked by people’s feet.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Hi Lifetime, thanks for getting back to me. Well I'll be honest and you may get a laugh out of this but for 2days I've been trying to fix the rear fog lights that were not broken, just not switched on, and know now are allocated through the tailgate I just didn't know I had them. The tail lights however, which I thought were allocated through the tailgate are in the rear compartment so my wife pointed out after wondering why it was taking so long to change a globe. How embarrassing. Wel to cut a long story short I eventually changed the right globes and all is good. Sorry for wasting everys time. Thank again for getting back to m. Some people should just leave it to the professionals.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks Chris no 10 all fixed now, I was changing the wrong globe I was trying to fix the rear fog light that wasn't broke. Had tail light mixed up with the fog lights, thanks for getting back to me
 
1 - 7 of 7 Posts
Top