RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Has anyone gotten aT-Mobile data SIM card to work in a 2017? I know from reading other threadsthat people have gotten T-Mobile SIMs to work in 2018's simply by plugging themin, I'm just not sure about 2017's...

I wentand got a T-Mobile data only SIM card today and plugged it in but can't get itwork. I stopped by the dealer and they of course told me that the only SIMcards that will work are exclusively AT&T. Any ideas on how I cantroubleshoot?
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
22 Posts
I had the same issue. Got it to work before but stopped working after taking the car in for service. The service writer told me there was a software update since but that's about it...

Sent from my SM-N950U using Tapatalk
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
In case anyone was wondering, I was able to resolve the problem at T-Mobile. I went back to T-Mobile and the guy immediately knew exactly what to do. Apparently there are 2 different types of data-only plans and he just had to change me over to the other type. As soon as he did that, the car started getting service. It's still funny to me that the dealership was super adamant that only AT&T SIM cards work in their cars.
 

·
Premium Member
Joined
·
1,854 Posts
'17 cannot get LTE, the chipset in it is 3G only - doesn't matter what SIM you put in.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
mmmkay,

Is your T-Mobile SIM still working ok? Also, are you getting LTE speeds or just 3G?

Thanks!

Jose
Yup still working, but like baxterdown said, I'm just getting 3G. It's fast enough for what I use it for.
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
469 Posts
So i assume only GSM networks...(ATT & T-Mobile)...Sprint and VZ are on CDMA
 
1 - 10 of 10 Posts
Top