RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
57 Posts
Discussion Starter #1
I have just purchased a 2011 full size Range Rover l322 supercharged. My engine has the symposer mounted to the back of the supercharger but the hose going over to the firewall like the l320's have is not there, and I don't see anything it would attach to either. Question is if mine is missing some parts or are all 2010-2012 s/c l322's like this with no hose(normal)? Any input greatly appreciated!
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
57 Posts
Discussion Starter #2
No takers? Anyone have a full size Range Rover 2010-2012 5.0 super charged with a plastic pipe (1")sticking up at the back of the removable engine cover? Maybe I should take a picture. It may be normal,maybe not. Thought maybe someone else had noticed it.
 

·
Registered
Joined
·
11 Posts
No takers? Anyone have a full size Range Rover 2010-2012 5.0 super charged with a plastic pipe (1")sticking up at the back of the removable engine cover? Maybe I should take a picture. It may be normal,maybe not. Thought maybe someone else had noticed it.
Take a photo and I’ll check mine tomorrow for you. Not sure what you are talking about, but if you circle it in your photo, I’ll happily take a look for you!


Sent from my iPhone using Tapatalk
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
57 Posts
Discussion Starter #5
Center of pictures, black tube with green o-ring on it. Nothing is attached or has fallen down behind it. Might be normal for a full size Range Rover 5.0. Any ideas welcome.
 
1 - 7 of 7 Posts
Top