RangeRovers.net Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi Guys,

I receive the following message "Suspension Fault" when i leave the car in "Park mode" for more than 5 seconds not always but specially after it's been driven and it's hot.
I can drive it with the message on without any problem and i can stop and start the car again and the message is gone.
Also sometimes i got this message when i raise or low the car suspension.
Do anyone have an idea why i got this message and what problem do i have in my suspensions?
Thanking you in advance for any help.

Best regards.
 

·
Registered
Joined
·
107 Posts
My RRS is 2014 model and i didn’t understand what “rig” means and thank you for the reply
It's related to your air suspension either the compressor that runs it as "Stemikel" stated or some other component related to the air suspension. Hopefully it's just a relay or a plug and play component and not the entire system that needs work/replacement. Are you still under warranty, or do you have an extended warranty? This was one of the systems that could go out mentioned by my dealer that that made me boost the extended warranty on my used 14' RRS Supercharged.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
It's related to your air suspension either the compressor that runs it as "Stemikel" stated or some other component related to the air suspension. Hopefully it's just a relay or a plug and play component and not the entire system that needs work/replacement. Are you still under warranty, or do you have an extended warranty? This was one of the systems that could go out mentioned by my dealer that that made me boost the extended warranty on my used 14' RRS Supercharged.
Hi. It's not under warranty anymore but why if it's the compressor i don't get this message when the car is running or stopped in D mode at Red light. The message i receive only in Park mode and after 5 to 10 seconds and sometimes when i raise or lower the car suspension !!! And even i can drive it normally with the message on !!!!
 

·
Registered
Joined
·
107 Posts
My RRS is 2014 model and i didn’t understand what “rig” means and thank you for the reply
It's related to your air suspension either the compressor that runs it as "Stemikel" stated or some other component related to the air suspension. Hopefully it's just a relay or a plug and play component and not the entire system that needs work/replacement. Are you still under warranty, or do you have an extended warranty? This was one of the systems that could go out mentioned by my dealer that that made me boost the extended warranty on my used 14' RRS Supercharged.
Hi. It's not under warranty anymore but why if it's the compressor i don't get this message when the car is running or stopped in D mode at Red light. The message i receive only in Park mode and after 5 to 10 seconds and sometimes when i raise or lower the car suspension !!! And even i can drive it normally with the message on !!!!
Broseph, I'm new here to both the forum and the SUV/Platform/Manufacturer... But after I posted to you last night I was curious as to your plight and wanted to help you out and at the same time save myself a headache if I ever had your problem. I ran across a thread that pointed to a brass fitting that is in the spare tire area of our Rover Sport Supercharged. Apparently, there is a brass fitting that can/does get clogged and won't let the "Air-Suspension" operate normally and either has to be cleaned or "reamed" out... threads words not mine... Once performed the thread posters said that their air system trouble codes went away and that their systems operated normally like new. I believe this thread was on page 4 or 5 of this very forum and when I get home I'll try and post it for you bro... Hopefully, someone from that particular thread with the knowledge will see your thread and my post and help you out before I can get the time to find the thread and posts I speak of. Good luck and I'll post back later on Toaoun...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
It's related to your air suspension either the compressor that runs it as "Stemikel" stated or some other component related to the air suspension. Hopefully it's just a relay or a plug and play component and not the entire system that needs work/replacement. Are you still under warranty, or do you have an extended warranty? This was one of the systems that could go out mentioned by my dealer that that made me boost the extended warranty on my used 14' RRS Supercharged.


Broseph, I'm new here to both the forum and the SUV/Platform/Manufacturer... But after I posted to you last night I was curious as to your plight and wanted to help you out and at the same time save myself a headache if I ever had your problem. I ran across a thread that pointed to a brass fitting that is in the spare tire area of our Rover Sport Supercharged. Apparently, there is a brass fitting that can/does get clogged and won't let the "Air-Suspension" operate normally and either has to be cleaned or "reamed" out... threads words not mine... Once performed the thread posters said that their air system trouble codes went away and that their systems operated normally like new. I believe this thread was on page 4 or 5 of this very forum and when I get home I'll try and post it for you bro... Hopefully, someone from that particular thread with the knowledge will see your thread and my post and help you out before I can get the time to find the thread and posts I speak of. Good luck and I'll post back later on Toaoun...
Thank you. I will be waiting for the thread and the post and hope that this will help :)
 

·
Premium Member
Joined
·
1,244 Posts
It's likely the desiccant drier. When it gets too much moisture it doesn't let air get in/out easily.
 

·
Registered
Joined
·
107 Posts
Thank you. I will be waiting for the thread and the post and hope that this will help :)
I'm looking for you noW Toaoun... I'm sorry I wasn't able to do so on Friday night. I had my corporate office Christmas Party @ 7pm on Friday Night that never seemed to end... Yesterday was oil change and tire rotation on the wifey's 15' Rubicon... Those 35' Nitto Mud Terrains did a number on my lower back. Then the SEC Championship and people over for that dismal response from my Almer Mater... Georgia. So I had a little more to drink than usual to drown my blues... I'm on my promise to you now though bra!
 

·
Registered
Joined
·
107 Posts
Alright "Toaoun"... As The Good Book Says... "Ask and you shall receive!"

It took me about 45 minutes to skim thru page after page until I learned how to run the "Advanced Search" feature on this forum. It's actually a pretty good search method especially compared to "other" forums for sure.

Here is the thread. Read all 33 posts because it is a good read and gets quite detailed and has a happy ending I remember correctly. I read this thread over a week ago though. I hope this helps you brother!

Here's the Thread Link
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Alright "Toaoun"... As The Good Book Says... "Ask and you shall receive!"

It took me about 45 minutes to skim thru page after page until I learned how to run the "Advanced Search" feature on this forum. It's actually a pretty good search method especially compared to "other" forums for sure.

Here is the thread. Read all 33 posts because it is a good read and gets quite detailed and has a happy ending I remember correctly. I read this thread over a week ago though. I hope this helps you brother!

Here's the Thread Link
Thank you for your help. Hope it will lead me to a solution :)
 

·
Registered
Joined
·
107 Posts
What i need to do? Change it or it can be cleaned/repaired?
Depending upon the cost of the OEM part itself from JLR... if it was cheap enough I'd just buy a new Desiccant Drier part myself... Unless it's something outrageously overpriced that is... of which I'd YouTube it and learn how to dry it out/repair it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
Depending upon the cost of the OEM part itself from JLR... if it was cheap enough I'd just buy a new Desiccant Drier part myself... Unless it's something outrageously overpriced that is... of which I'd YouTube it and learn how to dry it out/repair it.
ok thank you
 

·
Registered
Joined
·
107 Posts
Toaoun, did you get her back working properly your suspension? Any updates on how to fix?
 
1 - 15 of 15 Posts
Top