RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Suspension Error Messages

The first day I owned the RR Sport the Computer would sometimes display
"SUSPENSION VEHICLE RAISING SLOWLY"
Called several dealers and 1/2 said it was normal and the 1/2 said to bring it in.
Then about into the 3 day of ownership the Computer would also display
"SUSPENSION VEHICLE RAISING SLOWLY" and also
"SUSPENSION WILL RISE WHEN SYSTEM COOLED' Ambient Air Temp 96F
Now at 1861 statute miles I get this message
"SUSPENSION FAULT NORMAL HEIGHT ONLY" and
The DYNAMIC RESPONSE light show AMBER until you turn off the ignition.

Now sometimes when you restart the Amber light will illuminate and sometimes it will not and sometimes it will illuminate while driving.

Have an appointment with Dealer is 2 days. Hope they can get this fixed on the first trip. I love my RR Sport!
 

·
FOUNDING MEMBER
2013-2015 Range Rover Evoque
Joined
·
381 Posts
There have been problems like this described elsewhere LA, a faulty ECU connection and sensor were found to be the cause.
I occassionally get the Raising Slowly warning, pressing the gas pedal and giving the engine a few revs to help the suspension compressor seems to help and clears that alarm.
Tim
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Service SUCKS so far?????

Well was at the dealer today. They took the codes out of the computer and call Land Rover Tech Support. They could not tell me when they could get back to me, because Tech Support for Land Rover may call them in the next few days. They would call to let me know. I asked if my RR Sport has DYNAMIC RESPONSE SYSTEM.... The Service Dept said they don't know??????? :( Who Knows????? Service SUCKS so Far!
 

·
Registered
Joined
·
4 Posts
Re: Service SUCKS so far?????

LaBigDogs said:
Well was at the dealer today. They took the codes out of the computer and call Land Rover Tech Support. They could not tell me when they could get back to me, because Tech Support for Land Rover may call them in the next few days. They would call to let me know. I asked if my RR Sport has DYNAMIC RESPONSE SYSTEM.... The Service Dept said they don't know??????? :( Who Knows????? Service SUCKS so Far!
not especially what i wanted to hear since i am considered the RRS. keep us informed.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Well Today my RR Sport HSE went haywire too (again) with almost 2000 miles. Six warning lights came and remained on relating to suspension, ABS and parking brake as well as display warning of HDC and special systems failure also the Engine Fault message came up also. The speedo also stopped working. My Dealer said it all has to do with the suspension height sensor. It should arrive by Fed Ex in the AM... I guess we will see... :([/quote]
 

·
Registered
Joined
·
23 Posts
Hey LaBigDogs,

I had exactly the same issues at almost the same mileage here in London (see my post "TDV6 First Impressions" back in June).
Interesting huh! The answer turned out to be a faulty rear wheel speed sensor which explained the speedo (and probably the ABS light) and a loose ECU connector pin which explained the other warnings.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
RR SPORT STILL BROKEN!!!!!!

Here we go again.... My new RR Sport limped into the dealership with no Speedodometer and 6 lights on the dash glowing and error messages popping up so quick the computer was bong bonging to death (by the way it was the first time I drove it in a Rain Storm). The second I arrived they said with this many warning lights on it will take them some time, so they gave me a 2005 Perl White Cadillac Escalade it was a ride however it did not have spinning wheels. From Java Black to a Pearl Caddy...... At least it was not a Kia! :roll:

About 1 1/2 days latter the service writer called as said My new RR Sport is FIXED! At that time I also asked him if he fixed the Suspension Fault problem that I had since day 1. He Said that they did not have to replace the height sensor because all the problems I was haven was related to what they fixed?????? (I don't know about that) however he is the expert and I am just the owner. (I learned later is is ex-military) He will not sit still long enough to listen to me. He knows it all. (I learned this the first time I called the dealership to ask him about trailer brakes and he insisted that there were no provisions, and I knew there were) ........ He told me off at that time and quickly let me know his is the expert and boss, and I am the dumb owner and I should listen to him. :evil: (I am in my mid 40's have my Airline Transport Ratting, LR-Jet Rating, Single Engine Land and Sea, Multi Engine Land Commercial and Instrument Rating along with my ATP and this my 53 new vehicle I have bought in my lifetime. I know a little bit about systems and how they work - I am not totally dumb)

THIS IS WHAT REPAIR WAS DONE - 3 Large wire connectors on the front left wheel had water egress - He learned this through a Tech Support Bulletin - They had to open and pack the connectors with Electrical grease to keep the water out.

He also told me that a Tech Support Bulletin also noted that "SUSPENSION VEHICLE RAISING SLOWLY" and "SUSPENSION WILL RISE WHEN SYSTEM COOLED' are very normal and not a Fault.

They drove my new Sport around for me to pick it up... they also installed my new $300 floor mats. I get in and there is grease and mud all over the new front mats. I overlooked that as I knew I could clean them and would be able to get them back to new. Also one of the carpet pins was in the wrong place from the factory and the service writer said I would have to live with an extra hole in the carpet. O WELL once again! I was glad to get out of the Caddy and back into my RR Sport!

Today 1 hour after receiving my RR Sport back from the Dealership the "SUSPENSION FAULT NORMAL HEIGHT ONLY" and the The DYNAMIC RESPONSE light show AMBER

Now about 400 miles of the 2200 miles I have on my new RR Sport is Driving to the Dealer.... It is a full time job to try to get this thing FIXED!

I called today to tell Land Rover about the problem and the Service Writer for Land Rover was off so I spoke to the Jaguar service writer. He was very nice and listened to my story. He said to bring it in first think Monday. HERE WE GO AGAIN..... :cry:

This is the Problem I as still HAVING with the RR SPORT

The first day I owned the RR Sport the Computer would sometimes display
"SUSPENSION VEHICLE RAISING SLOWLY"
Called several dealers and 1/2 said it was normal and the 1/2 said to bring it in.
Then about into the 3 day of ownership the Computer would also display
"SUSPENSION VEHICLE RAISING SLOWLY" and also
"SUSPENSION WILL RISE WHEN SYSTEM COOLED' Ambient Air Temp 96F
Now at 1861 statute miles I get this message
"SUSPENSION FAULT NORMAL HEIGHT ONLY" and
The DYNAMIC RESPONSE light show AMBER until you turn off the ignition.

Now sometimes when you restart the Amber light will illuminate and sometimes it will not and sometimes it will illuminate while driving.
 
1 - 7 of 7 Posts
Top