RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
177 Posts
Discussion Starter #1
Hi guys,

I've been having starting issues with my p38..

When it's left overnight it turns over for a while before it starts, I've replaced the sender unit & pump, also put a none return valve just before the filter, replaced the leak off pipes..

However, I've just pulled the leak off pipe on injector 1 (while running) to make sure that the fuel is pumping through correctly and managed to get a small pool of diesel in the recess where injector 1 is.. I then noticed that there was air bubbles coming from the pool of diesel..

I then got a screw driver to slightly pry the injector to see if it got better or worse & it got worse.

Have a look at this video (if you can see it): https://instagram.com/p/BT9p24Bj3eg/

Can someone please help me with this?

Am I right in thinking that the injector seating seals are gone?
Can someone help me locate the replacment parts & a guide?

Could this cause the starting issue?

Sorry to bombard with loads of questions & many thanks in advance

Ash
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,426 Posts
I looked at replacing the copper washers under the injectors and I couldn't source any.

I would get the proper injector socket (with the cut out) and tighten them to the correct torque setting as per RAVE.
 

·
JACK'S GRANDAD
Joined
·
9,242 Posts
As well as putting all the rigs information in your sig line, if not in each and every thread.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,295 Posts
1 - 4 of 4 Posts
Top