RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
In the beginning.....

And then in november 2009.... (P38 MY 2000 with Bosch management system)

today my car gave me yet another nail to the coffin.... just installed a new belt tensioner and cleaned the IAC and throttle body with special cleaner from Belladd - some sort of spray you inject - which turns into foam - work really great!! - anyway also installed Magnecor 8mm ignition leads - WOW... no more noisy tensioner (the V8 actually sounds really great LOL) and the idle has become much more even and reduced the idle to 550 rpm's

BUT - another problem has reoccured (been gobne for some years - never found the fault though) driving on the highway - 120 - 140 km/h the engine suddenly dies for half a second and then comes back to life..... driving a constant speed (both with and without the cruise control) this happens.... several times in a row - then nothing for a long time and then again..... it even shifted downa gear and rewed like hell doing 140 km/h on my way to work this morning (just for a few seconds - but quite scary - I know it's an automatic - but I don't want it to things like that....

the cut-off.... could it be the fuel pump (relay is fine!) or should I expect coild packs - leads are new magnecor and the spark plugs are less than a year....

What should I look for now?! :cry:


I really love the car ( and yes I think of it as family!!) :dance:
 

·
Registered
Joined
·
401 Posts
fuel pumps tend to only last 200k kms check that first if it hasn't been changed. You could drive a little slower if it solves the problem... haha :D
 

·
Registered
Joined
·
275 Posts
Discussion Starter #3
Mine has "only" done 150.000 km - i.e. approx. 94.000 míles - so maybe it's all over for the rover'.....

The problem was already there at 80.000 km then gone - then comes back - gone for a looong time - and now it's back

- and ALWAYS at a steady speed - 122km/h / 134 km/h and now at 140'ish km/h

how about the TPS? or the MAF..... think I'm gonna change it all.... h.ll why all the electrics while I'm at it LOL!!!!

Thing about owning an English car - you NEVER feel alone and without trouble - there's always something to repair / fix / modify....


Ferdinand -

Quote Dire Straits:
"When my ugly big car won't climb that hill, I'll write a suicide note on a hundred dollar bill"

No, I'm NOT suicidal - just love the song and laugh every time I hear that sentence...
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
865 Posts
Bosch controlled engine.....mmm me thinks engine ecu is over heating, if Im not mistaken there is a cooling fan that provides 'air' to cool the ECU, wonder if this fan is working, Bosch ECUs are a known minor problem area, not all but some.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #5
where to look- can't remember where it is placed - to tired right now - seem to remember hearing some tiny fan somewhere - but right now... no clue....

Ferdinand - any help is most welcome!!!
 
1 - 6 of 6 Posts
Top