RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
21 Posts
Discussion Starter #1
Hey all, don’t have access to the RAVE manual right now as I can only access internet through my phone.

I’m towing a trailer in the US that has a 4 pin connector on it. I had the adapter working and left on my trip only to have it catch on something and rip off. I see 6 wires hanging from the Range Rover.

Red, yellow, blue, white, and two black ones.

Anyone know which 4 I need to connect to this generic 4 pin I got?

Need ASAP.

Thanks so much.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,088 Posts
Suggest you get a test light and use it to find out which wire is which, one would be the earth, prob black. Otherwise need the model to look up the right wiring diagram.
 

·
Registered
Joined
·
1,104 Posts
Hard to say not know where these wire are. You say the adapter is in place, is the break after that? Or are these P38 wires? Normally a flat 4 has the following:
Yellow - Left turn
Green - Right turn
White - ground
Brown - taillights
The brake lights are combined with the turns . So I would find the corresponding wires on your P38 using a test light and connect the this color scheme on the plug.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
21 Posts
Discussion Starter #4
Ok, so I think I have this narrowed down.

There are 7 wires on my RR so I bought a new 7 spade plug set from Pep boys and hooked it up. Plugged In the test light and it showed that the tails are working and the blinkers are working on The test light.

I assume the brake lights should illuminate the test led for the blinkers...but it’s just blipping real quick and then staying dark.

As for the trailer, I’ve check all the wiring and it looks good. Tails lights work. No blinkers or brake lights. What could this be?!

Thanks again for everyone’s help.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
21 Posts
Discussion Starter #5
Another thought...is there is something wrong with my 7 spade to 4 pin adapter?

I get the “Trailer Warning” light flashing intermittently on the dash.
 

·
Super Moderator
Joined
·
2,318 Posts
Not sure how it is supposed to work when you've added the adapter for your American system but by design the green trailer warning lamp isn't a warning, it's a confirmation that the trailer indicators are working. It should flash in time with the indicators when a trailer is connected, if it doesn't it's telling you a trailer isn't connected or you've got a blown trailer indicator bulb.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
21 Posts
Discussion Starter #7
Interesting, that clears some things up.

Anyway...here are my tests. The trailer works fine. Hooked up to another truck with no issues. So I’m back to figuring out the wiring in the RR.

The test light shows only tail lights working. I’d like to test the wires coming out of the truck now. What am I looking for...12v on flashing?

Also...where SHOULD the wiring go if done correctly? To the turn signals and the brake lights run off same wiring?

I’m so confused!
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
21 Posts
Discussion Starter #8
Oh wait. Never mind. I figured it out. Euro 7-pin layouts are different than US 7-pin.

Anyone know where to get a new euro 7-pin plug for the truck side? I have the adapter already.
 
1 - 8 of 8 Posts
Top