RangeRovers.net Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
553 Posts
Discussion Starter #1
Whilst cleaning my car today I came accross a small cable sticking up between the pasanger seat and the centre console it has two wire and a connection at one end , I have been getting a FUSE 10 message on my dash for ages now and am wondering if this has not got something to do with it maybe it is a wire that has come loose?
 

·
LIFETIME CONTRIBUTOR
2002-2005 Range Rover MkIII / L322
Joined
·
5,424 Posts
What are the wire colours. That will narrow it down quite a lot.
 

·
Registered
Joined
·
553 Posts
Discussion Starter #4
I cant follow it because it bisapears into the depths of the cenre console under the carpet layer it looks like a standard range rover fitting not anything aftermarket. I think the wires are black and white not sure will make sure when I get a chance.
 

·
Registered
Joined
·
553 Posts
Discussion Starter #7
Im not sure its a 96 and I have never had the seatbelt warning sign on also I cant see and wire coming out of the seatbelt connection
 

·
Registered
Joined
·
317 Posts
Nod.

Not activated for all markets. I have a similar wire on my UK '96 but no matching connector on the seatbelt receptacle.

Tuck it back under the carpet!

David
 

·
Registered
Joined
·
553 Posts
Discussion Starter #10
Thanks for the info regarding the seat i will stick that wire back under the carpet, regarding the FUSE 10 issue the dash says FUSE 10 blown but the fuse is 100% nothing wrong with it at all but it keeps saying fuse 10 blown
 

·
FOUNDING MEMBER
Joined
·
4,509 Posts
dave-the-diver said:
Nod.

Not activated for all markets. I have a similar wire on my UK '96 but no matching connector on the seatbelt receptacle.

Tuck it back under the carpet!

David
:D I've unplugged mine to get rid of the lawyer bell...(I do wear my belt all the time, don't need to be reminded rudely..)
 

·
Registered
Joined
·
553 Posts
Discussion Starter #13
Fuse 10 on the BECM fuses is fine! I dont understand why it always registers the Fuse being blow when it is fine
 

·
Registered
Joined
·
453 Posts
if fuse 10, (1 to the left from top right of the becm fuse box) is ok and it shows fuse blown it could be a loose fuse, corroded connection between fuse box and fuse or bad contacts within the becm fuse box or along the route to the RH seat.

No easy one there, follow the circuit and try to find a bad joint.
 

·
Registered
Joined
·
553 Posts
Discussion Starter #15
My heated seats dont work the fuse has obviously something to do with it I did try wiggling the fuse around but no luck. I thinkk my first step will be to remover the BECM and see if there is nothing obvious in there I can see after that will have to follow the circut and see whats happening
 
1 - 15 of 15 Posts
Top