RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello,

Three times in the past 2 months I get a strange "twittering" alarm sound inside the cabin. Two of the times it was while I was driving and one (this week) when I opened the drivers door. It is not that loud (not deafening) and only last for about 15 - 30 seconds. The times it happened when I was driving; I had no messages on the dash and this weeks was just getting something out of the Rangie. Looking back; I did not do anything different than I normally do on a daily basis. Does anyone else have the same problem and/or know what it might be?? The Rangie is a 2005.

Thanks,
Michael
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
42 Posts
Michael, I have this same problem on occasion also. Must be an 05 Westminster thing ;)

It has only happened to me once while actually driving. The other "few" occasions seem to be mostly when there is no key in ignition when the passenger door is opened prior to the driver's door :think: . Last time at the dealer - i couldn't reproduce it - go figure :doh: . It might be your ECU Fan starting to fail. Is the sound coming from behind the glove box?

mb.
 

·
Registered
Joined
·
14 Posts
I had an annoying beeping sound on my 2010 HSE. It ended up being the wireless remote control for the video system which is stored and charges in the compartment situated in the middle of the rear seat.
Probably doesn't hep you though ......
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
mb,

Yes; it is coming from that area, as you said, it must be an 05 Westminster thing. `) If I ever figure it out; I'll let you know.

Thanks,
Michael
 
1 - 4 of 4 Posts
Top