RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,806 Posts
Discussion Starter #1
So, it was really foggy this morning... went to turn on the fog lights due to really bad visibility and they did not work. I spent about 20 minutes looking at fuses and getting annoyed. Then I tried moving my headlight switch from "auto" to "on" and then they worked.

This seems really stupid if that is by design. The owners manual does not mention anything about it... is this another weird electrical issue that I need to debug, or is this a "feature"? I subsequently moved it back to "auto" and the fogs stayed on :?
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
101 Posts
Just checked this behabvior on my truck and on my '07 SC the fogs will only work if the headlights or parking lights are on...regardless of whether you're in auto mode or have overridden that function. And likewise, will turn off or will not illuminate if the headlights or parking lights are not on...again regardless of switch position.

So unless when you went to turn them on there was too much ambient light to trigger the auto headlamps, but that when you went to turn them off, there was lower light, allowing the headlights and thus the fogs to stay on...you have a glitch it would seem.

Your fogs should have either been able to turn on while auto was selected, or shut off when the switch went back to auto (depending on if it was dark out or not at the time), doing neither sounds like an issue...again, unless there was a changed ambient light condition.

-John
'07 RRSC
 

·
Registered
Joined
·
1,806 Posts
Discussion Starter #3
The headlights were on the whole time yeah. *sigh*

I still didn't get around to replacing my questionable battery yet so... before I go too crazy I might want to try that. Especially since a weak battery would place extra load on the alternator, and I wouldn't want to cause an additional problem.
 

·
Registered
Joined
·
1,806 Posts
Discussion Starter #4
Ok, I feel dumb now :oops:

I figured out it was because DRL are enabled on my vehicle so even though the lights were on, they were in DRL mode, not because it sensed that it was dark. The fogs are working fine.

I'll turn those off when I get my IIDTool, those are annoying. I'll turn my lights on if I want them on dang it.
 

·
Banned
Joined
·
901 Posts
pretty sure my fogs only work on "ON" anytime, auto at night doesn't trip them. I've been in a couple other cars like this so I think its by design.
 
1 - 5 of 5 Posts
Top