Range Rovers Forum banner

1 - 3 of 3 Posts

·
Registered
2007 Land Rover Range Rover 4.4
Joined
·
52 Posts
Discussion Starter · #1 ·
Hello looking for some help on my 4.4 2007 RR. Just yesterday I had a little fun and did some mudding (nothing crazy just some medium sized puddle on a dirt road) I left drove back home after my little bit of fun shut off the car. Then about 2 -3 hours later I go out to grab a snack. While driving i notice that when I drive straight going a decent speed the wheel feels like its stuck and requires more effort to move then after that effort it moves fine. Seems to only do it while coasting (like on highway or driving down the road). When breaking or standing still its perfectly fine. I have not check the fluid level yet but this doesn't seem like a fluid level issue as while standing still its perfect. I have already sprayed to all down to remove any mud and also went through a car wash just to be sure. I will do further inspection tomorrow to see if maybe i missed a spot. Please let me know if any one has any idea of what could be wrong.

Things I have recently done to the car:(not sure if any of these would cause this issue but thought I would mention it)
1. Changed thermostat
2. Changed ABS front wheel sensor
3. Drain and refill both front (using 75w90 lucas) and rear diff (using LR electronic locking diff fluid)

Thanks in advance,
Ethan
 

·
Registered
2007 Land Rover Range Rover 4.4
Joined
·
52 Posts
Discussion Starter · #2 ·
Did also check the power steering fluid and it is full and clean
 

·
Registered
2007 Land Rover Range Rover 4.4
Joined
·
52 Posts
Discussion Starter · #3 ·
Hello though I would make a post updating the situation. I did get it all fixed thankfully!! Turns out the rack was just dirty. I simply removed some power steering fluid from the reservoir. Then add about half a can of seafoam transtune to the system let it idle and drove It for a few. Then BAM! All fixed!. Then later I also removed some of the power steering fluid and added new fluid now it works great! Though I would just share this incase anyone else has these issues.
 
1 - 3 of 3 Posts
Top