RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I have a friend with a 99 RR with the factory Alpine stereo. Last week it somehow stopped functioning. It is stuck on one radio station, and none of the buttons on the stereo or steering wheel are responsive. IE He cannot turn it off, change the volume, station, etc.

Is this a common problem? Does anyone have a recommended fix? IE would pulling the battery for 5 min, or taking the stereo out to fully power it down fix this? is there something inside that could have popped that he could fix with a simple solder?

Thanks for the help!
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
164 Posts
You could try disconnecting the battery and shorting the positive wire to ground on the vehicle for several minutes. This will rapidly discharge any capacitors in the electronics and hopefully reset things. No need to remove the radio to try this. All of the window settings will be lost and electronic keys will need syncing using the procedure in the manual.
 

·
Registered
Joined
·
985 Posts
I have never had this problem. But I think it might be less hassle to pull the radio. You can easily make keys from hanging file dividers. No need for buying special tools. I had mine out in minutes. Since there is a good chance that the "reboot" isn't going to work anyway, might as well have the tools. Roverville radio repair will fix it probably within their flat rate and clean out the controls while its there. Their info is on the main page of suppliers. I used them for a repair and it came out perfectly and no hidden costs.
 
1 - 3 of 3 Posts
Top