RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
2010-2012 Range Rover Sport
Joined
·
12 Posts
Discussion Starter #1
From time to time and always after driving in the rain, my 2011 RRS HSE radio sound cuts out for awhile. After sitting overnight, it always resumes normal sound operation. Logic would dictate that something is getting wet and temporarily causing the problem until it dries out again. I've searched for TSB's but have not found one that addresses this problem.

Anyone else experienced this problem and if so, what is the remedy?

Thanks, usmcfred
 

·
SUPER MODERATOR
2006-2009 Range Rover Sport
Joined
·
4,458 Posts
Check that the passenger foot well is not soggy or wet, this is where water accumulates if the sunroof drain channel gets plugged up. When water pools there, it gets into the wiring loom beneath the hard plastic cover near the door step and can corrode connections underneath. Usually this results in items such as front driver's window or passenger window not functioning, or electric seat controls not working, but could also be influencing the radio. The amplifier is underneath the passenger seat...check to make sure all items are not wet there either.

The cure is to clean out the sunroof drains...plenty of threads on how to do that...you'll find information easily available here on the forum on how to clear that.

Also check the rear quarter panel where the bluetooth module is and make sure water is not seeping into that, as it's all connected by the MOST fiber optic ring, and if that is getting wet, can also kill the signal to the radio.
 
1 - 2 of 2 Posts
Top