RangeRovers.net Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Just got my 06 RR and i noticed that the two speakers on the very rear near the parcel shelf dont make any sound. Went around the verified that all door speakers including the sub woofer are ok except for those two in the back. I could see a speaker inside. BTW i have just the plain Harman Kardon with no Logic 7. Did i miss any setting?
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
If you don't have Logic7, are there speakers in the back enclosures at all?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
They are the speakers on the back pillar, flanking the rear glass door. They have speakers inside visible through the grill and facing the front of the vehicle. No sound coming out at any volume level. Thinking maybe it 4" by the looks of it.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
Just checked mine, the sound is somehow different (less clear) compared to the front and side speakers but there is sound coming from them. The speakers seem to be the same size as the middle ones from the doors.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
I wonder what wrong with mine then. Could i have a blown amp? They could just be filler speakers...to put out bass maybe? Im pretty sure they are there for a reason. :(
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
Hey, why didn’t I think of this earlier? Just went to the car and depressed the virtual Logic7 button on the screen and guess what? No sound at all in the rear speakers! So they only work when Logic7 is enabled!
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
Now im even more confused :) bec your saying is turns on when you disable Logic 7 which my vehicle doesnt have. I just have the plain Harman Kardon system. Im sure if those speakers werent made to produce any sound, LR would not have bothered installing it in my vehicle. Thanks BTW for doing all the testing for me. I will start searching around the amp area to see if there are any unplug wires.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
Read your post again...sorry i misunderstood you. Ok now it makes sense. They are meant for the Logic 7 system :( . Now if i could find a way to retrofit that system. :roll:
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
What's odd is that Land Rover would install Logic7 surround speakers even in cars that don't have the built-in surround sound processor. I thought all 2006 HSE Range Rovers came standard with HK Logic7 sound system... Or perhaps it's just for North America spec cars (can't tell if the original poster is in the US)?

PS. Never mind, I found out on another thread that philrover is in the Philippines. It would really help if all forum members included their location as part of their profile when they register.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
I can assure you that although there is a difference in sound, it's not as amazing as they advertize it... My previous LR3 had a non Logic7 system that sounded WAY better that the one in the RR...
 

·
Registered
Joined
·
159 Posts
adara said:
I can assure you that although there is a difference in sound, it's not as amazing as they advertize it... My previous LR3 had a non Logic7 system that sounded WAY better that the one in the RR...
i agree... although i love my RR and it's sound system, my prev ride was an old ('01) mercedes s 430, just plain jane, and i've gotta tell you that the sound system was easily twice as good. I know that that's comparing apples to oranges but it's just that there seems to be so much hype about this logic7 stuff, whereas my almost 10yr old mbz with a stock bose system was so much better. i paid $18,000 for that mercedes in 2006, then paid multiple times that to buy my RR and was hoping to really be blown off my feet. i'm still happy with the car though. wouldn't trade it for an s class that's fo' sho'!
 
1 - 11 of 11 Posts
Top