Range Rovers Forum banner
1 - 5 of 5 Posts

·
Registered
2006-2009 Range Rover Sport
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I'm new to this forum, so apologies if this has already been covered before.

I have a 2007 RRS and there is no longer any sound coming from the stereo or Sat Nav, although otherwise they appear to be in perfect working order. Strangely it would appear that the stereo is stuck in mute, as when I turn the stereo volume knob up and down the volume level (numbers) no longer appear in the LCD display panel.

I have taken the car back to the LR dealership and they want to replace the head unit for >£600. I have disconnected the battery for a hard reset myself to no avail and the LR dealership tried the same and have done everything they can think of to get working.

They are now suggesting a replacement head unit. However this seems like a software problem to me?

Any advice would be greatly appreciated, thanks

Andy
 

·
Premium Member
Joined
·
1,266 Posts
Did you try increasing/decreasing from the steering wheel to rule out the knob on the head unit?

There was a software update for the headunit freezing around 2009 for VINs in 06-08 RRS. The freezing may not be your issue, but a possible update may reset your head unit?
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply, I have tried to adjust the volume via the steering wheel controls, but this also has no effect.

I'm going to remove the head unit and check all the connections to see if that helps. I will also check with the dealership whether that can do the software upgrade for me.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,015 Posts
Under "Vehicle has no sound but everything otherwise is working correctly", the old infotainment system diagnosis says it could be a "Failed EQ download, muting amplifier" and calls for a "Hard reset and then upload latest software to IHU / HLDF / Amp." See: https://www.box.com/rrs/1/651860233/6145543179/1 - has your dealer attempted a software upload of all the latest patch files to all those modules yet?

Failing that, you may have no choice but to bite the bullet of the head unit replacement recommended by your dealer. Keep us posted!
 

·
Registered
Joined
·
1 Posts
Hi, I'm new to this forum, so apologies if this has already been covered before.

I have a 2007 RRS and there is no longer any sound coming from the stereo or Sat Nav, although otherwise they appear to be in perfect working order. Strangely it would appear that the stereo is stuck in mute, as when I turn the stereo volume knob up and down the volume level (numbers) no longer appear in the LCD display panel.

I have taken the car back to the LR dealership and they want to replace the head unit for >£600. I have disconnected the battery for a hard reset myself to no avail and the LR dealership tried the same and have done everything they can think of to get working.

They are now suggesting a replacement head unit. However this seems like a software problem to me?

Any advice would be greatly appreciated, thanks

Andy
Try turning Bluetooth off that worked for me
 
1 - 5 of 5 Posts
Top