RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
LEGACY VENDOR
Joined
·
2,492 Posts
Discussion Starter #1
Hi,

Temp is arount 0°Celsius and my radio doesn't want to speak.

LCD doesn't even work and no sound at all except a sort of whine.

If i warm the inside for 45 mins or so, it makes a woof :lol: sound and everything is all right.

Any idea?

Thanks

Florent
 

·
Registered
Joined
·
86 Posts
Funny you mention that...Since owning my '02, here in Wisconsin, we get sub temps during winter months...I noticed after my first cold spell, radio and nav would freeze(no pun)up...I would have to shut off ignition and wait until the "buzzing" sounds stops from the speakers...Restarted and radio/nav came on as it should...This only happens below 32 F...I'm on my second year of owning my Range and I just learnt to deal with it...I also have a headlight(DR high beam)that hasn't worked either since I owned...These are the only electrical gremlins I have had and from reading many posts of BeCM on here, I would consider myself lucky... :thumb:
 

·
LEGACY VENDOR
Joined
·
2,492 Posts
Discussion Starter #4
0°Celsius = -26° F
 

·
Premium Member
Joined
·
1,802 Posts
Zero Celsius Equals Plus 32 fahrenheit
Zero Fahrenheit Equals Minus 18 Celsius

As I think there may have been some erroneous signs on this thread so far.
 

·
Registered
Joined
·
53 Posts
Ooh in our recent cold spell my heater has come up with the book symbal stayed for 5 days and went.

Mine is converted to run LPG and on starting runs fine on petrol for about 2 mins then when it turns over to LPG it cuts out and wont start for around 45 mins but if I run it on petrol for around 5 mins (at start) it is perfect then switch it to LPG it's fine too!!

And Friday night just gone whilst driving about 50 miles in -7c or around 18F I got a EAS hard fault and was forced to drive 40 miles at 35 mph (Well ok I was doing 45!!), cleared faults on it sat morning started it up to build up pressure in system and it was fine and couldn't find a fault and has been fine since..... Done another 70 miles today and was perfect???

So mine isn't the only one not to like the cold?? :thumb:
 

·
Registered
Joined
·
226 Posts
My rover hates the cold as well, the eas never drops in the summer or in the garage, but outside in frigid temps it'll drop to the stops. Just changed the head gaskets which only leaked in the winter, tranny still makes funny sounds when very cold.
 
1 - 9 of 9 Posts
Top