RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
2016-2018 Range Rover Sport
Joined
·
297 Posts
Discussion Starter #1 (Edited)
2018 RRS
Just noticed my steering wheel controls and skip function randomly do not work. This is on all media sources.
When this happens, I can’t access the menu either.
Wondering if others have the same issue?
Dealer does not have a fix for it yet.



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1 Posts
Holeecow,
I have had the same issue with my 2018 RRS HSE. It only happened to us when the weather was at or near freezing. Also had an issue during cold weather where the remote start feature wouldn't work. I'm wondering if there is a bad connection somewhere in the electronics that "disconnects" when it's cold. Shrinking metal causing an air-gap in the electrical connections.

I'm taking it in to have a hitch installed and the tech is going to look at this issue as well. I'll post again if they have an answer for me.
 

·
Registered
Joined
·
1 Posts
Yes, I have had this same issue with my 2018RRS. We noticed that it didn't work when temps were under 40* . . . anytime over that it worked so we also thought it was just a loose connection. I recorded it on my phone and played it for the service advisor at my appt. My dealer ordered a replacement and it is being installed tomorrow.
 

·
Registered
2019-2021 Range Rover Sport
Joined
·
25 Posts
I've had this issue too on my 2018RRS. Sometimes I wonder if it's the capacitive switch not working or if the computer is frozen and jumpy...
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
297 Posts
Discussion Starter #6
I haven’t noticed it acting up lately.
They did some update to try tog at my cellular hotspot working. But it didn’t work.

But since then, the switches are working.
Could be coincidence?


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top