RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all,

My 07 RRS HSE just started having this issue with the steering audio selector buttons, none of them do what they are supposed to, the volume up-down button will change audio source or change station, the phone "end call" button will also select a different audio source, the horn works and the rest of the cruise control buttons work, but the ones for audio are doing something different.

Does anyone know how to get rid of this issue?

Thanks!

Tex
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
517 Posts
My 06 just started having this problem. Did you ever fix yours?


'06 RRS LUX
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
517 Posts
Well I found this on landroverforums.com that tells about water causing the problem which makes sense as my problems started soon after i left the sun roof open and it rained. Basically you remove the steering wheel and controls and clean everything with electrical cleaner. I did this and all is back to normal. There is a youtube video showing how to remove the airbag then the wheel.

The remote control run is a two wire circuit that goes thru the rotary coupler clock spring to allow wheel to turn and make contact; and then there are multiple buttons. Note that a resistor is in series between each button. Back in the radio head unit the resistor value is calculated and it "knows" which button has been pressed. But if there is any corrsion on the contacts of the connectors from the radio to the clock spring to the module that can make resitance chage as well. Corrosion loves to change resistance in temperature swings. I guess you could warm up an area of the steering wheel with a hair dryer (warm, not melt) to test.




'06 RRS LUX
 
1 - 3 of 3 Posts
Top