RangeRovers.net Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
293 Posts
Discussion Starter #1
OK so took my 03 HSE down to the store and when i jumped in i adjusted my seat, mirrors, steering column cause my wife had been driving. Drove down to the store turned the RR off and the steering wheel goes up and in to let me get out. I do what i gotta do, get back in the RR and the steering wheel wont adjust. I drive back home and after just checking things out i find out that the driver seat controls are not working either.

So...
all buttons and controls on the steering wheel ARE working, but the steering wheel wont move with the adjustment lever, in any direction.
NO seat controls on the driver seat will work, memory buttons, nothing. Heated seat DOES work. Passenger front seat controls DO work.
basically everything but those two functions work.

checked the fuses, fuse 20 operates both of those functions, but the fuse was intact..

fuse 23 operates just the steering column and it too is intact.

Any ideas here? anyone have this happen before?? Is it possible that a fuse is bad even though it is intact and not broken??? (i did not try changing the fuse since it was still intact, i placed it back in)

thanks in advance...
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
Did you check the multiplug under the seat?
 

·
Registered
Joined
·
293 Posts
Discussion Starter #3
uh... no i did not, brb...
 

·
Registered
Joined
·
293 Posts
Discussion Starter #4
Ok, forgive my idiocy here, the MKIII i dont know so well...

so where is the multiplugs you are referring too, i didnt see anything under the front seats, and i checked the rear cargo area fuse box where there about 6 or 7 multiplugs are those the ones you are talking about, if so is there a map to tell me which multiplug would control the seat and steering wheel???
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
There is only a multiplug under the driver's seat, about 1/3 from the front end, it has contacts for the seat's motors, heating, pretensioner...
 

·
Registered
Joined
·
293 Posts
Discussion Starter #6
ok yah the rectangular yellow one with black plugs plugging in to opposite sides, i disconnected that one and took a look, looks fine, reconnected it and still no mojo...
 

·
Registered
Joined
·
293 Posts
Discussion Starter #7
Ok i just realized earlier i was thinking "relay"s when you were talking about multiplug, either way the multiplug was all connected up...

i also swapped out the fuse, even though it was not blown, still no change...

anyone have any ideas at all???
 

·
Registered
Joined
·
1 Posts
I'm having the same problem on my 2005 HSE. I've checked every plug under the seat and replaced every fuse. One odd thing is that the fuse for the seat and steering adjustment sparks (if the car is on or the key is in the on position) when I put it back in. Additionally, the passenger seat adjustment won't work if the drivers seat fuse is in. Any ideas?
 

·
Registered
Joined
·
238 Posts
You have three memory buttons on the driver seat, do they activate seat, steering wheel ( only with ignition on) and mirrors?
 

·
Registered
Joined
·
1 Posts
I have the same problem with my 2002/2003 MKIII HSE Range 4.4

When I try to move the steeringwheel or electrical seat nothing happens. It only "clicks", but nothing happens.

Suggestions?
 

·
Registered
Joined
·
293 Posts
Discussion Starter #11
check out the post titled "fuse blows twice"

its more than likely a short inside the seat fromt he lumbar support...

a quick temporary fix is to unplug all of the seat control multiplugs right at the seat control (remove the fascia), replace the fuse #20 if its blown, and then plug everything back in EXCEPT the lumbar adjuster... youll be without lumbar support but you will have seat controls and your steering column adjustment back.
 

·
Registered
Joined
·
2,475 Posts
For me it had to do with a wire to a motor shorting inside the seat... You can either figure out what motor it is, and unplug that harness from the seat control panel. Now you're left with a working seat/steering column but without the use of the one shorted motor you unplugged.

Or you can pull the seat out, remove the leather, and fix the short...

For me it was the lumbar motor, so I just set the lumbar where I wanted it, then unplugged it... I can get it to work for a few days by reaching up inside the seat and pushing the wires towards the motor, but after jumping into the car a few times it usually becomes dislodged and blows a fuse.
 
1 - 12 of 12 Posts
Top