RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
1970-1995 Range Rover Classic
Joined
·
88 Posts
Discussion Starter #1
Recently my 95 classic stopped starting intermittently. Lights, radio, etc all worked - battery has 12.5ish volts. No cranking, no clicking. Sometimes it would start, sometimes it wouldn't. I thought it was probably the starter since I had a vehicle in the past do the same thing. I installed the starter and still nothing. Crap.

Next, I located the starter relay in the right kick panel - there are 2 yellow relays that look pretty much the same except a small printed number - I looked at the wires coming from the ignition and figured out which one it was. I pulled the relay out put it back in and now I just get the classic clicking solenoid and then everything goes dead. I have to turn the truck completely off and then back to ACC and I get lights and radio again. Any idea what's going on here?
 

·
Registered
1995-2002 Range Rover Classic
Joined
·
1,413 Posts
loose or dirty connection somewhere possible at starter and or battery terminals, remove, clean, inspect and service as needed to include all connection points and replace any failed terminals or cables, both ground and power.
 

·
Registered
Joined
·
65 Posts
I was having intermittent starting issues, and as well as replacing the starter, I replaced the positive and negative battery cables. Atlantic British sells a convenient kit, but you could save significant money by getting them made locally. After replacing the cables and the starter, my issue was solved. The cables were significantly corroded, but the starter was weak too.
 

·
Registered
Joined
·
1 Posts
I had the same issue, replaced the starter and the new one was doing the clicking noise too. I cut the negative battery cable and installed a new negative battery terminal. Haven't had any problem since.
 
1 - 5 of 5 Posts
Top