RangeRovers.net Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
First off, I tried searching this forum looking for anyone experiencing this problem for hours, and I may be doing something wrong, but I couldn't find anything related to it. If you have a link, please feel free to post it for me, but before jumping on me, please know that I really tried.

Okay, now for the problem. I have a 2003 Range Rover Westminster with 60k miles. For about a year now, when I would get in, sometimes when I turn the key to start I would get just a click at the starter. I would then have to recycle the ignition key and it would start after 1 or 2 times of just the click.

Yesterday morning, I had the radio on and the battery went dead. I put the charger on (2 amp, deep cycle) and it took a charge. Now when I turn the key to start it, all of the lights come on, but the starter does absolutely nothing. No click, no crank... nothing. Everything else seems normal. All of the lights in the dash come on as normal and everything seems fine other than no cranking or even click from the starter. I'm not sure that the battery dying is related as it's happened before, but it hasn't started since it died this most recent time.

I have trust issues with most mechanics, so I do all of the work on my own car. With this particular problem, I don't know where to start. Also, the nearest dealership is almost 2 hours away and the tow fee would be silly, not to mention the cost of repair(s). Is it a starter problem? Is it a computer problem?

Someone please help me. Any info you could give is highly appreciated and I give infinite thanks for anything anyone can do to shed some light on this problem.

I have the notify box checked, and I will also include my phone number if someone would rather just call. Thanks again.

I love this forum BTW, and I am on here all the time reading all of the great info on what has become my favorite ride of any I have owned.

Don
(518) 275-3119
 

·
Registered
Joined
·
1,119 Posts
I am no mechanic but I would check the electrical/battery connection to the starter motor as this may have worked loose.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Sig and location added. Sorry, I didn't even think to do it.

I am going to test the voltage at the starter, but it's very difficult to see up there. I'm now downloading the RAVE, and being that it's huge, it's taking some time. I want to be sure which connections are which, and I can't see them clearly enough to tell just by looking.

Could a weak battery cause this problem? Or perhaps my charging and trying to start it using the start on the charger? I tried starting it with the charger in "start" mode and it clicked 3 times, then not even a click since. I am having other minor problems as well over the past couple of months.

1. The steering column does whacky things. On entry, sometimes it will try to go all the way down, and on exit, sometimes (always now) it goes to the highest point and the motor just humms. I stop it manually.

2. Three times now, the dash lights have all come on. HDS inactive, Susp inactive, ABS lights, etc. Then I get out and go back 20 minutes later, and I have to reset them via the lock to lock with the wheel, then fine for a week.

3. Nav unit and will go off and reboot? while driving.

4. Check engine light came on twice, read and reset fuel/air code. Fine now.

Now I have the car in my garage and I can't start it. Battery has been charging for a full day, and still nothing. Someone please help. Thanks.
 

·
Registered
Joined
·
1,367 Posts
Hello, Don.
WELCOME TO THE FORUM!!!! :dance:


Replace your battery.
Call me a rocket scientist, but my guess is that where you live (NY) is very cold lately.
Cold temperatures are tough on batteries.
My guess is that your battery began degrading, oh, maybe about a year ago.
Interstate Battery (among others) makes a great replacement battery.
In anticipation of your next question, I don't know the battery model off the top of my head, but if you search the MKIII forum, you can find it's already been asked & answered.
Yes, a weakening battery will do most of these things & more to a MkIII RR.
You can try charging a degraded battery all you want, but when as it degrades, it's pointless. If this is the original battery, it's served you very well.
As far as your steering column, that may be another issue, then again, maybe not.

P.S.:
Probably and hopefully the battery will take care of it & you won't need to replace your alternator/regulator.
And hopefully your Rover isn't kept where rodents may want to use it as a home & gnaw your wiring harness to shreds, which would also do things like this.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Thanks for the info. It hasn't been clod here at all, averaging around 40 degrees, and the car is parked in a heated garage when it's not being driven. There is no chance that a rodent even gets a look at this car.

The odd thing is that the battery took a charge and shows good through all tests. What I don't understand, why would this all still happen with the charger connected? There is plenty of power behind the battery with the charger at 100 amp start. Additionally, a bad battery usually won't take a charge.

I was looking to save on the cost(s) of pointless part replacement, but I will go for the new battery anyway. I'm really hoping it's not an ECU problem.

Thanks again guys.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
The fun continues...

It wasn't the battery. Battery swapped, same thing.

I then decide to check every fuse in the car. Starting in the glove box, I pull and check every single one of them. Perhaps, in retrospect, not the best idea... Now, the key buttons don't work (yes, I tried reprogramming as per the instructions in this forum several times), the interior lights don't work, rear windows don't work, the steering column is dead, and probably many more things that I have yet to notice, and the same problem I've been having hasn't changed. Turn the key, dash lights up fine, nothing at start position.

I'm getting the feeling that this is going to cost me a small fortune. I really feel like setting fire to it now.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Okay, I was able to jump the starter, and with the ignition key in the run position, I got the starter to crank but the car did not start. What would control both the starter not cranking with the key, and when I bypass that, not starting when I do get it to crank? Engine Control Module (ECM)? Engine Immobilazation ECU? Relay Interlock?

Secondly, how would I go about testing the components to see where the problem lies?

Any help is greatly appreciated as I am very worried here.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
I wrote 2003, but it's actually a 2004. I make the mistake all the time when searching for parts or on the forum because I know the 2003 and 2004 are the same.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
The battery is new and didn't change a thing.

To reiterate, with the key in position 2, I jumped the starter and was able to get it to crank, but it still did not start. Tomorrow I am going to spend the day following the circuit and see where the problem is and the voltage stops.

We'll see, I guess. There are a lot of sensors and ECM type components to check.
 

·
Registered
Joined
·
65 Posts
RE: Starter / Starting Issue

I have the exact same thing happen, every once in a while w/o rhyme or reason, on our 2005. That issue, that is the starter. The problem is - it is difficult to really pin point because that issue does not store codes (failed start). But what you explained with 'everything working fine except it won't start (summary)' - that's something I've been having to deal with for a while. Annoying as hell. Am sure it is the starter; I know the tech at our LR dealer & my buddy is a tech for a BMW near where I live, I've explained the situation, he thinks it is a starter.

The other issues, don't know.
 

·
Registered
Joined
·
1,367 Posts
I am so sorry that my hipshot suggestion was not correct & costed you the price of a new battery. I know they are not cheap. But the sypmtoms you described sound so much like a typical weak battery problem.
Maybe a problem with the regulator?
How old was the battery that you replaced?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
No worries, Mark. It was 2 years old I think, but I can sleep now knowing it's done anyway. I had the car towed up to the dealer yesterday, I'm up to $632 for a new key and the 3 hours they spent diagnosing it which I firmly believe is NOT the problem. They told me it would take an hour to diagnose it before I had it towed there, then they tell me today that it took 3. Over $600 strikes me as insane, and I think its this reason I won't own another land rover product again. I love the Range, but that's just criminal.
 
1 - 15 of 15 Posts
Top