Range Rovers Forum banner
1 - 5 of 5 Posts

· Registered
2006 Range Rover Sport Supercharged
Joined
·
15 Posts
Discussion Starter · #1 ·
I have an 06 Range Rover HSE and I had some loud squeaking about a month ago which sounds like the belts. I had the serpentine belts replaced. The sound went away for about a week and a half. After that it returned! Then I had the tensioner replaced. Sound came back after two weeks! Oddly enough, the sound only occurs when I crank up the truck in the morning when it's cold outside. At times, well, most of the time, after driving it for some time, the sound goes away. The mechanic shop that I went to doesn't seem to quite know what they are talking about, as if they are guessing.... What could be the problem?
 

· Registered
Joined
·
721 Posts
Idler pulley?

I think there was a TSB issued for that exact reason.
 

· Registered
2006-2009 Range Rover MkIII / L322
Joined
·
38 Posts
Is it a squeaking, chirping sound that sort of chirps repeatedly or is it a continuous screech? If it's a repeated chirp, I believe it is the idler pully tsb. My 2006 was doing the same thing once it started to get around 50 degrees and below on cold starts. After it warmed up it went away. It annoyed me so I had LR do the TSB and it has since went away. Cost about $385. I did just hear a quiet little chirping yesterday, but it was 2 degrees and was only on initial start up (lasted maybe 10 seconds) haha. The TSB should fix it right up! It's expensive but no one wants a squeaky range rover!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top