RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have some 12,000 miles on this RRS Dynamic and recently started having the following problems: 1. the driver safety features have gone haywire - sometimes veering the car violently into one or the other direction (no cars going by), 2. on a steep uphill the RR slows to a crawl like around 1,000 rpm regardless of how much we step on the accelerator. Has anyone experienced some similar behaviors.

My action so far has been to have my dealer check the car; they found nothing but reset all the electronics... this was last week and the uphill issue remains. I've turned all of the driver assistance options off yet the veering issue has happened twice, though not violently.

Would appreciate anyone's feedback. Thanks!
 

·
Registered
Joined
·
134 Posts
Have you had them ride along with you so you can demonstrate what's wrong? A vehicle veering violently due to electrical problems is no joke. They should want to get that car off the road and fixed asap.
 

·
SUPER MODERATOR
Joined
·
27,705 Posts
If all the assist programs are shut off, then how can the assist systems be causing the tissue? Sounds more like the alignment has been knocked out of spec or a failing suspension component.

Your throttle lag on hills would not be connected to your steering issue. It's under warranty, drop it off at the dealer but be sure to call ahead for a loaner.
 

·
Registered
Joined
·
2 Posts
2. on a steep uphill the RR slows to a crawl like around 1,000 rpm regardless of how much we step on the accelerator. Has anyone experienced some similar behaviors.
We’ve experienced this when on cruise control and you go on the throttle to override. Turning off cruise control seems to release the throttle and/or allow gear kickdown.



Sent from my iPhone using Tapatalk
 
1 - 4 of 4 Posts
Top